FreePBX | Register | Issues | Wiki | Portal | Support

DAHDI Trigger Voltage


(Gprimr1) #1

I have a situation with my installation that’s causing some trouble. One of the DAHDI FXO ports is connected to an automatic ringdown circuit provided by the phone company.

The line is split so that it both goes to the PBX and to two phones in the station. One is a public phone outside, the other is a phone in the elevator.

I’m having an issue where voltage varies and it will start the phone ringing and complete the circuit and call our dispatcher.

So my question, is there anything I can do to stop this? Can I edit a setting to raise the voltage threshold to trigger the ringer, or put a line filter?


#2

It’s not actually the voltage as a a problem, , it is the current. (It’s an ohms law thingy :slight_smile: and FXO’s are current loops)

Now the Dahdi FXO is probably about 0.3 max, so if your other two devices plus the Dahdi FXO exceed the current provided by the Telco, you will need a “ring booster”, try Viking, perhaps


(Gprimr1) #3

So I would buy that and place it between where the wire is split to go to the phones and the PBX or before that?

I’m reading some of the comments and I just want to make sure that this is the right device. This sounds like it is a booster for making phones ring. That’s not the problem.

The issue is that no one is calling, and the FreePBX, and only the FreePBX thinks that someone is calling.

I just want to make sure this device will fix that before I buy it.


#4

If I understand correctly, your fxo is spontaneously going offhook, triggering a false call on the PLAR circuit.

I had a similar intermittent problem with a local hotline to an intercom on a fxs circuit and was only able to “fix” it by switching from a Channel Bank input to a Digium card. Pretty obscure problem that I spent a lot of time troubleshooting to no avail.


(Gprimr1) #5

That’s almost the problem. It’s a little more weird.

The logs show the PBX starts DAHDI Channel 4 (the line it’s connected to) the phones connected to the PBX ring.

If you pick one of them up, there is a 15-30 second silence while the PLAR circuit connects to dispatch.

So its ringing the phones, but it’s not actually completing the circuit with the PLAR until you answer the phone.

The card is one of those Chinese imported cards. I’m wondering if there’s something physically wrong with the card.


(Gprimr1) #6

I put in a genuine Astrick card tonight, let’s see if that helps.

Also, wondering if there would be any benefit to using Loop Start since it’s an old PLAR line.

Also purchased shielded phone line to run between the PBX and the wall tap.


(Tom Ray) #7

You should find out from the Telco if it’s Ground or Loop start. That is a configuration on their end that you need to match. If they have ground start and you use loop start (or vice versa), it’s going to cause problems.


(Gprimr1) #8

I spoke too soon.

I tried adding the new genuine Asterisk card. When I tried calling the PBX, it doesn’t pick up. When I put the old card back in, worked fine.

One thing I noticed; when I go into the web portal, it says “FXO 1, 2 FXS 3, 4”

When I go into SSH dahdi_cfg -vvv it says “FXO 3, 4 FXS 1, 2”


(Gprimr1) #9

Realized I never posted a reply on this. I think the card may have been starting to fail. I replaced it with a Cisco SPA3102 and the problem went away.