DAHDI - Toll free numbers: "The number cannot be completed as dialled.”

FreePBX 2.10.58
Asterisk: 1.8
(Distro: 1.815.210.58-1)
4x port analog card with four lines. (POTS)

Hi All,

So, this box I installed in one of our remote branch offices is giving me so many headaches; the latest is people keep telling me that when they try to dial 1800 (toll free numbers) it rings for a bit then they get the message "The number cannot be completed as dialled.” I’m not sure why this is happening as only happens with toll free numbers; other outbound calls seem to connect fine. this is the setup:

– Trunks –
Trunk Name: 6173574800
Outbound CallerID: 6173574800
Maximum Channels: 1
Zap Identifier: 1

Trunk Name: 6173574801
Outbound CallerID: 6173574801
Maximum Channels: 1
Zap Identifier: 2

Trunk Name: 6173574802
Outbound CallerID: 6173574802
Maximum Channels: 1
Zap Identifier: 3

Trunk Name: 6173574803
Outbound CallerID: 6173574803
Maximum Channels: 1
Zap Identifier: 4

– Outbound Routes –
Route Name: 6173574800
Route CID: 6173574800
Dial Patterns: ()+ |[X./4800] - anything from extn 4800
Trunk Sequence: 6173574800

Route Name: 6173574801
Route CID: 6173574801
Dial Patterns: ()+ |[X./4801] - anything from extn 4801
Trunk Sequence: 6173574801

Route Name: 6173574802
Route CID: 6173574802
Dial Patterns: ()+ |[X./4802] - anything from extn 4802
Trunk Sequence: 6173574802

Route Name: 6173574803
Route CID: 6173574803
Dial Patterns: ()+ |[X./4803] - anything from extn 4803
Trunk Sequence: 6173574803

So, i’m told 4800 and 4803 can make outbound calls to toll free numbers but 4801 and 4802 can’t.

Does anyone know why this would be happening or where I should be looking to figure out what is wrong?


Since you’re using POTS lines, can you plug a phone directly into the DEMARK and dial properly?
What happens if you swap the trunks for 4800 and 4801. Does the problem follow the trunk, or stay with the port?

Finally, although this is an old TRIXBOX post, the information is still valid when dealing with POTS lines as trunks.



Step one, create a generic outbound route and verify all trunks can reach those numbers from any extension…

Is the message you are receiving generated from the PSTN or from asterisk? Sounds like the pstn to me, Check your dialing rules… one trunk may be sending incorrect digits.

OK - so I have tested all lines and it seems only one connects correctly. I have checked and the message is after connecting to the pstn and not an asterisk message.

These are pots lines so figured it ignored the CID but still have tried the CID per analog line (so if the line DID is 6173574801, I’ve passed 6173574801 and also tried 16173574801.)

Still doesn’t work so not sure what to check next.