DAHDI Module missing

Newbie to FreePBX Here. Doing a new install. I have a Digium TE121P T/1 Card. I installed 64bit version of FreePBX. Tried both 4.2.x and 2.1 Distro installations. I’m reading the wiki on getting the card to work. Only problem is I cannot fin the DAHDI module anywhere. I know its installed by default. It says to click on Connectivity, then it should be there, but it is not. I’m including a picture of what I see. Can someone point me in the right direction?


It’s not installed by default. You must install it from Module Admin.

ok, so then how do I install it. I’m assuming I goto admin/module admin, then click on upload modules. So where do I download the DAHDI module from so I can install it?

Just a side note. I can root into the box, run amportal stop, then run service dahdi start. Everything comes up ok, green light on the card. So I know the card is working. I guess all I need to do is install the DAHDI module, but for the life of me can’t find it anywhere. What am I missing?

ok, I’m making progress I think. I downloaded DAHDI from downloads.asterisk.org however I think this is just drivers or something not the module because I can’t install it. Sorry for being so “wet behind the ears” on this one.

I am reading that Schmoozecom has the DAHDI module, but still can’t find where to download… :frowning:

FreePBX, Module Admin, Enable all 4 repositories at the top of the screen then click the ‘check online’ button. DAHDI Config should appear in the Connectivity section.

ahhh … that was my problem… I didn’t have all of them highlighted when I clicked check online… got it. works now. I knew it was something simple… uggg.