FreePBX | Register | Issues | Wiki | Portal | Support

Dahdi issue freepbx 14 wont start on boot


(JarJar Swope) #1

Hello, after upgrading to Freepbx 14, a major problem started.

When you restart the pc, it does not recognize the FXO board.
So I can not make or receive calls.

In principle when I put dahdi_tool nothing appears to me as if no board was connected.

Now what I have to do to start/excecute this steps

  1. service dahdi start ( after this step, the card appear on dahdi_tool)
  2. dahdi_genconf
  3. Then in the control panel enter the connectivity - DAHDi Config - Analog Hardware - press Edit button and then in the 4 buttons put
    Group 0 and in Context from-analog

(James Zhu) #2

please check by run linux command: lcpci, make sure the card can be detected. what kind of cards? sangoma card or others?


(JarJar Swope) #3

Digium - Wildcard TE131 or TE133 cards qty 2.

If i run these steps it works fine but when i reboot it stops starting and i have to run

  1. service dahdi start ( after this step, the card appear on dahdi_tool)
  2. dahdi_genconf
  3. Then in the control panel enter the connectivity - DAHDi Config - Analog Hardware - press Edit button and then in the 4 buttons put
    Group 0 and in Context from-analog

#4

When you have DAHDI working to your satisfaction, you don’t need the FreePBX helper any more (as you see, it doesn’t) disable it, everything will be just dandy from that point on, and you won’t be ‘reset’ on every reboot/restart. It’s a little complicated to explain but it is a channel driver that has it’s own service that is best started by root before asterisk or FreePBX start.


(JarJar Swope) #5

ok but how to i set the group numbers in then?


(JarJar Swope) #6

if i run fwconsole restart when the server boots it is fine. When i don’t dahdi is sad


#7

they should still be there in “/etc/asterisk/chan_dahdi_additional.conf” if the helper didn’t change them, which it won’t if it is not running


#8

Yep, it’s still not well thought out. Just disable the helper and all your problems will go away :slight_smile:


(James Zhu) #9

maybe the PCI-ID of cards has been changed if rebooting the system.


#10

That can’t happen, it is embedded in the hardware unless you otherwise manipulate it in udev.


(JarJar Swope) #11

OK so how do i disable the helper? @dicko


#12

Did you not look in the module admin page yet?