Dahdi echo cancelling not working

Hello All,

I discovered that within the configuration /etc/dahdi/system.conf the setting of:


The echcocanceller setting is not being saved, so even though you tell it to enable echo cancelling you still get an echo.

After playing around with the GUI I couldn’t find any setting that would add this configuration line back into system.conf.

I do see chan_dahdi.conf having echocancel=yes, echotraining=800, echocanceller=1

I do believe the system.conf entry is required.

what hardware?
run fxotune -i 4

One solution is to disable the dahdi helper module in FreePBX. Then it won’t overwrite any customizations you need, IMHO oslec is a better echo canceller if you have it installed . As James said, you need to tune your FXO lines with fxotune (and adjust your rx/txgains for milliwatt equality) prior to trying to reduce echo out of any echo canceler.

It’s a digium 4 port card, not sure the exact model, it’s a little older.
If I run fxotune will it save the appropriate settings in the configuration file automatically?

It will create /etc/fxotune.conf which will be loaded on boot if you have fxotune -s in your /etc/rc.local, You should look at

man fxotune

for options that you might want and how it all works.

thanks for the pointer!