DAHDi Doesn't appear to be running

DAHDi Doesn’t appear to be running. Click the ‘Restart DAHDi & Asterisk’ button below.

This is a PBXact 60 unit with a factory loaded card in it. Ever since power on we get this error message. Everything else in the phone system is working right.

However when I go to DAHDI Config this is what I see:

This is suppose to be a 2 port FXS, 6 port FXO card. I dont see the 2 FXS ports listed and no matter what I do I cant get the DAHDi service to start. Is this most likely a bad card?

I cant make phone calls and this phone system has to be live on the 10th… starting to panick. :slight_smile:

Is this something I should open a support ticket with sangoma for?

I’d start looking at the dahdi_* tools before submitting any tickets.

DAHDI has nothing to do with FreePBX, except that certain cards (including many Sangoma cards) have a module that allows you to optionally manage it through the GUI. After a couple of years trying to do it that way, most people get tired of banging their heads against door frames and desks and manage it with the dahdi_* tools that are installed when you install DAHDI.

I had a problem like this and it ended up being an invalid Echo Cancellation setting on the FXS ports.

Okay. This is only 2nd system with an analog card. It is using a sangoma card. I dont have my head totally wrapped around FXO and FXS yet. I deal with SIPTrunking 99% of the time.

FXO = Lines from the Phone company
FXS = Analog Phones on the internal side

Is that correct?

Whats interesting is if I run:
[[email protected] ~]# dahdi_cfg -vvvvv
DAHDI Tools Version - 2.11.1

DAHDI Version: 2.11.1
Echo Canceller(s): HWEC

Channel map:

Channel 03: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 04)
Channel 05: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 05)
Channel 06: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 06)
Channel 07: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 07)
Channel 08: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 08)

6 channels to configure.

Setting echocan for channel 3 to oslec
Setting echocan for channel 4 to oslec
Setting echocan for channel 5 to oslec
Setting echocan for channel 6 to oslec
Setting echocan for channel 7 to oslec
Setting echocan for channel 8 to oslec

Its calling them FXS ports and not FXO ports. this is a 6 port FXO card and 2 port FXS. However in the web interface its showing me FXO ports 3-8 are active. and does NOT show FXS ports

so i finally got into SSH for this server and found this under dahdi_tools:

Whats interesting is…this isnt a PRI card. Its saying there is 24 channels. This is an analog card. Am I having some type of driver conflict?

I am doing a lot of research on DAHDi and trying to learn the tools but i cant find any good write ups out there that really explain anything. I have been on digiums kb’s, freepbx wiki, even google isnt shooting back a whole lot of information

Also when I run this:

[[email protected] ~]# dahdi_scan
description=wrtdm Board 1
manufacturer=Sangoma Technologies
location=SLOT=4, BUS=7

Ports 1 and 2 should be FXS.

okay after a whole crap ton of guessing i used wanpipe_cfg to rebuild the cfg files. They are now active.

I still dont have any FXS ports but I am not using them. As long as its working its all i care about

I know i am talking to myself here but this may help someone in the future. Even after changing a setting as simple as Tx/Rx Gain in global settings and savings i have to go back to SSH and rebuild the config files again.

Go through the settings that make sense for your setup
Save and Restart at the end (Option 1 i believe)
At that point my error goes away and everything works