Dahdi custom tone region


(Jelani) #1

Hi I’ve just setup FreePBX. I have a FXO card installed and it’s been detected by dahdi. I’ve setup a ring group to hangup for testing purposes but when i call the POTS line, it just rings out. I have a hutch it’s caused by the tone region setting.

I live in the caribbean (st. lucia) and there is no region setting for the island. I’ve been testing a few tone settings but with no luck… I know the island’s tone settings but i don’t know how to configure Dahdi to use them… Please assist.

Tone settings required
COUNTRY/TONE FREQUENCY in Hz CADENCE in seconds

Saint Lucia Busy tone - 425 0.5 on 0.5 off
Congestion tone - 425 0.25 on 0.25 off
Dial tone - 425 continuous
Special dial tone - 425+330 continuous
Pay tone - 622 0.136 on 0.136 off
Ringing tone - 425 0.375 on 0.25 off 0.375 on 2.0 off
Route tone - 425 0.05 on 0.05 off
Warning tone - 425 0.1 on 4.9 off
Call waiting tone - 425 0.2 on 0.2 off 0.2 on 4.0 off


(Jelani) #2

I also get this error when i try to call the POTS line

WARNING[13503][C-00000006]: app_macro.c:321 _macro_exec: No such context ‘macro-from-dahdi-3’ for macro ‘from-dahdi-3’. Was called by s@from-analog


#3

Exactly what issue is it that you are trying to fix?


(Jelani) #4

The call rings out and does not make it to the inbound route


#5

That is probably not related to the tone settings.
Do you have a ANY/ANY inbound route?

Post a log of an incoming call. If your log doesn’t show a message like “starting simple switch on DAHDI” then something is misconfigured.


(system) closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.