DAHDI config module: when disabled, fwconsole no longer starts or stops DAHDI

I just want to make sure this is normal behavior when the DAHDI config module is disabled. I discovered this after running into some issues with my Allo BRI card drivers after compiling and noticing that during boot, there is a script running somewhere calling up the genconf script which wipes out my /etc/dahdi/system.conf file. Until I can find whats doing that, I have disabled the FreePBX DADHI module since it does not like anything changing in that file and its faster to just manually overwrite, run fwconsole restart, and/or service dahdi restart, then have to configure all my dahdi spans again through the UI.

I am using FPBX v13.0.46 with all the latest updates as of today.

if DAHDi config is disabled fwconsole won’t start the drivers. Thats the way it’s written on purpose.

This was a bug and was fixed 27 days ago. You should upgrade dahdi config.

Enabled/installed DAHDI config today with the latest v13.0.9 and same problem after doing a full system reboot from System Admin :cry:

I am guessing that these Allo dahdi patches that I had to run to get my BRI card to work has to do with it. Looking over comments and notes from the fixes, I am not sure this addresses the same exact problem. I will just stick with having a backup of my config files and leaving DAHDI config disabled for now. If you need me to provide more info in a new or current bug report, or here, to help address this, please let me know.


You can also disable dahdi config from writing configurations. It’s in advanced settings. I dont think this is a bug and since we don’t support the Allo cards its hard to even make a diagnosis