DAHDI Channel DID is not parsed by Incoming Route

DAHDI Channel DID is not parsed by Incoming Route.
If the incoming route is blank (All DIDs) the call is routed
and proceeds.
If a value is entered in the Incoming Route = DAHDI Channel DID.
The DID is not detected and the error message “The number you have dialed is not in service…” is played.
I have a generic TDM400 board and need to route channels to different IVRs.

Please provide info on this issue.

Art

Log for failing mode:
– Starting simple switch on ‘DAHDI/1-1’
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,userfield) VALUES (‘CHAN_START’,{ts ‘2014-02-05 00:21:48’},’’,’’,’’,’’,’’,‘s’,‘from-pstn’,‘DAHDI/1-1’,’’,’’,3,’’,‘1391577708.20’,‘1391577708.20’,’’,’’,’’)]
– Executing [[email protected]:1] NoOp(“DAHDI/1-1”, “No DID or CID Match”) in new stack
– Executing [[email protected]:2] Answer(“DAHDI/1-1”, “”) in new stack
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,userfield) VALUES (‘ANSWER’,{ts ‘2014-02-05 00:21:49’},‘Cell Phone VA’,‘7573090120’,‘7573090120’,’’,’’,‘s’,‘from-pstn’,‘DAHDI/1-1’,‘Answer’,’’,3,’’,‘1391577708.20’,‘1391577708.20’,’’,’’,’’)]
– Executing [[email protected]:3] Wait(“DAHDI/1-1”, “2”) in new stack
– Executing [[email protected]:4] Playback(“DAHDI/1-1”, “ss-noservice”) in new stack
– <DAHDI/1-1> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Executing [[email protected]:5] SayAlpha(“DAHDI/1-1”, “”) in new stack
– Executing [[email protected]:6] Hangup(“DAHDI/1-1”, “”) in new stack
== Spawn extension (from-pstn, s, 6) exited non-zero on ‘DAHDI/1-1’
– Executing [[email protected]:1] Macro(“DAHDI/1-1”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/1-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“DAHDI/1-1”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“DAHDI/1-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘DAHDI/1-1’ in macro ‘hangupcall’
== Spawn extension (from-pstn, h, 1) exited non-zero on ‘DAHDI/1-1’
– Hanging up on ‘DAHDI/1-1’
– Hungup ‘DAHDI/1-1’
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,userfield) VALUES (‘HANGUP’,{ts ‘2014-02-05 00:21:56’},‘Cell Phone VA’,‘7573090120’,‘7573090120’,’’,’’,‘h’,‘from-pstn’,‘DAHDI/1-1’,’’,’’,3,’’,‘1391577708.20’,‘1391577708.20’,’’,’’,’’)]
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,userfield) VALUES (‘CHAN_END’,{ts ‘2014-02-05 00:21:56’},‘Cell Phone VA’,‘7573090120’,‘7573090120’,’’,’’,‘h’,‘from-pstn’,‘DAHDI/1-1’,’’,’’,3,’’,‘1391577708.20’,‘1391577708.20’,’’,’’,’’)]
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,userfield) VALUES (‘LINKEDID_END’,{ts ‘2014-02-05 00:21:56’},‘Cell Phone VA’,‘7573090120’,‘7573090120’,’’,’’,‘h’,‘from-pstn’,‘DAHDI/1-1’,’’,’’,3,’’,‘1391577708.20’,‘1391577708.20’,’’,’’,’’)]

To properly route the pseudo DID’s of dahdi (if you set them up) you would need to use context from-dahdi, from-zaptel or from-analog as appropriate to your deployment and not from-pstn as you are apparently currently using.

FreePBX 2.11.0.18
Asterisk 11.7.0
CentOS release 6.4 (Final)

dahdi-channels.conf ? under [channels] ?

wiki?

google?

I checked those resources and no clear indications as to how to
context=from-analog in chan_dahdi.conf as indicated in FreePbx
(no change) or some of the other solutions.
I basically need info on what files to concentrate on.
Thank you.
Thank you
Art

Did you setup Dahdi Channel DIDs correctly? This is inside freepbx and has to be done before you can assign routes to anything coming over dahdi

http://address/admin/config.php?display=dahdichandids

Also if you setup your dahdi cards through the freepbx interface the context would have already been set correctly. Since you did it manually here is a sample configuration from FreePBX in chan_dahdi_groups.conf which is included by chan_dahdi.conf (which you’d need to make sure you included it or add this data to chan_dahdi.conf)

; [span_1] signalling=pri_cpe switchtype=national pridialplan=national prilocaldialplan=national group=0 context=from-digital channel=1-23

signalling=fxs_ks
context=from-analog
group=0
channel=>31

signalling=fxs_ks
context=from-analog
group=0
channel=>32

signalling=fxs_ks
context=from-analog
group=0
channel=>33

signalling=fxs_ks
context=from-analog
group=0
channel=>34

signalling=fxs_ks
context=from-analog
group=0
channel=>35

signalling=fxs_ks
context=from-analog
group=0
channel=>36

signalling=fxo_ks
context=from-analog
group=0
channel=>25

signalling=fxo_ks
context=from-analog
group=0
channel=>26

signalling=fxo_ks
context=from-analog
group=0
channel=>27

signalling=fxo_ks
context=from-analog
group=0
channel=>28

signalling=fxo_ks
context=from-analog
group=0
channel=>29

signalling=fxo_ks
context=from-analog
group=0
channel=>30

Here are a my 10 cents.
To change the DAHDI config used at run time to show the desired context.
by means of dahdi_genconf, dahdi show status must show the desired context.

  1. FreePBX 2.11 “Add DAHDI Channel” states to assign the channel’s context to from-analog for the settings to work. BUT it really doesn’t specify where.
  2. To do all channels, vi /etc/dahdi/genconf_parameters
  3. go to about line 46, “#context_lines from-pstn”
  4. add “context_lines from-analog” right below it, without a #
  5. Save file
  6. dahdi_genconf
  7. dahdi_cfg -v
  8. service dahdi restart
  9. service asterisk restart
  10. for your viewing pleasure, at the asterisk CLI.
  11. dahdi show status.
  12. dahdi show channels

you will have to find out how to do individual channels,
but this is a better starting point than wiki or google,
and having the info.

WorkOfArt

Thanks for your response.
Did you setup Dahdi Channel-yes
Did you setup Dahdi Channel DIDs correctly-yes
Setup your dahdi cards through the freepbx interface the context would have already been set correctly=Install default.
-I didnt make any changes, setup install - no changes, when I came to connect and test POTS lines, I couldn’t route them other than to a blank (any DID) inbound route.

chan_dahdi.conf: changing to context=from-analog in [channels] was a no fix.

I don’t understand well this file, But i would like to know how to do individual channels. using TDM400s, say chan 4 context=from-analog and chan 2 context=from-pstn.

WorkOfArt

You are welcome. I’m glad you learned to fish.

Been doing this since 1975… Just needed a quick answer that wasn’t there… I guess you want money.

I gave you the correct answer in ten minutes. consider it a free gift.

Yes you gave me an answer, and correct, but…
you provided no solution…
well, your solution was wiki or Google.
Don’t flatter yourself too much.

Given your 38 year experience in doing this you far exceed any one elses experience here maybe in the next 38 years you will realize that your false sense of hyper-entitlement will neither be accepted or appreciated by anyone you ask for help from here, get of your duff and actually start to learn what you are trying to doing OK?

And Im closing this thread now. You’ve both had your say. If you would have installed the “dahdi configuration module” in the first place we wouldn’t have gone through this, it’s easy to tell you didn’t install it because it sets from-analog by default.