Dahdi - Busy signal when called, won't dial out

Hello again… This is becoming kind of a habit, but i’ve tried everything else. Here’s what’s going on now.

I just installed the latest distro (Stable-4.211.64-7) with asterisk 11.5.1. Config went fine with no errors. Set my inbound/outbound routes, extensions, and all that up in the GUI. Went to test the system, and much to my surprise, it doesn’t work!

I unplugged the POTS line from my Digium TDM-400P Card and plugged it into an old analog phone. Incoming and outgoing calls work fine on the analog phone (the phone company is safe for now). I plug it back in to the server, and when I call the server from an outside line, I get a busy signal?!

Even stranger yet, when i attempt to place an outbound call from one of my IP phones, it gets to where I should hear ringing, but there is nothing, and the phone I’m calling never rings.

I’m stumped.

Description Alarms IRQ bpviol CRC Fra Codi Options LBO Wildcard TDM400P REV I Board 5 OK 0 0 0 CAS Unk 0 db (CSU)/0-133 feet (DSX-1) Chan Extension Context Language MOH Interpret Blocked State Description pseudo default default In Service 1 from-analog en default In Service 4 from-internal en default In Service

Nothing here looks wrong… There are no error messages in the GUI, and I’m not sure where else to look.

Hopefully you guys will have some ideas for me!

Thanks for the help!


I forgot to mention that when I call an internal extension from another internal extension, everything works just fine.

from-analog looks wrong, how did you set up your dahdi channels?

Everything automatically configured. I did try substituting from-pstn but that didn’t seem to have any effect.

It does not just configure itself. Do you have the DAHDI module installed? It works very well now.

Yes I do have the DAHDI module installed. It is detecting my card and modules.

Still no answer, please help.

It’s hard to believe you have no logs. Without logs there’s nothing we can do to help. Try running:

asterisk -rvvvvvvvvvvvvvvvvvvvvv