Custom ring for internal extensions but affects queue?


I want to setup a different ring for internal calls vs. external calls. I have setup the following in extensions_custom. All my internal extensions are 1xxx.

exten => _1XXX,1,NoOp(“setting custom ringtone for internal extensions”)
exten => _1XXX,n(set-ring),Set(__ALERT_INFO=)

I thought it was working perfect, but calls which hit our overflow queue are also catching this when it rings the internal extensions. What is the best way to prevent this?

Also – with latest version you can only do Sangoma ring types and not standard bellcore ones…


No it’s a drop down and a free form in one. You can still type in a custom alert info

It most certainly is. Thanks Tony!

I think my solution is this:

Setup the Queue to have (the standard ring as all the other SIP trunks) and then do this in the custom configuration:

exten => _1XXX,1,NoOp(“setting custom ringtone for internal extensions ${ALERT_INFO}”)
exten => _1XXX,n,GotoIf($[“x${ALERT_INFO}” = “x”]?set-ring:no-set-ring)
exten => _1XXX,n(set-ring),Set(ALERT_INFO=)
exten => _1XXX,n(no-set-ring),NoOp

Basically, add the alert info if it is not already set.

Am I missing anything.