Custom Recorded message not playing

We have created a new recording for the IVR but when you call in it just plays dead air. All the press x for this press x for that options all work, but it will not play the audio.

I’ve checked the file permissions on the mp3 and everything I know to check, I’m sure its something silly but i’m out of ideas.

I ran into the same thing with my setup and then found out the file has to be encoded just right. I took my wav files and and ran this command on each to get them to work. (I ftp’s the files to the asterisk box, then ssh’d into it to run this)

sox inputfile -r 8000 -c 1 outputfile resample -ql

hope this helps

I tried the sox trick as mentioned above, but still no sound.

I found the following in the log file…

[Mar 8 14:09:19] WARNING[1454] file.c: File custom/bnIncomingWDir does not exist in any format
[Mar 8 14:09:19] WARNING[1454] file.c: Unable to open custom/bnIncomingWDir (format 0x4 (ulaw)): No such file or directory

I’ve used two versions of the file, a wav and a gsm both give the same error