Custom follow-me caller-ID on internal->internal->followme calls

Is there a way to change the caller-ID on an internal->internal->Followme call?
I am trying to find a way when one employee rings another employee, and it routes to their followme, to have it use a set callerID.

The only way I can think to do this is to setup a custom outbound route for each extension, and only allow from that extension, to a particular outbound caller ID, but that sounds painful for a large number of extension and possible routes… is there any easier way?

Note: Normal incoming (from external) calls Follow-me is working fantastic, and passing the callerID as desired, I just want to change the internal->followme caller ID…
x107 calls x106
x106 is out at lunch, so it routes to his followme on his cell.
Currently it goes out the trunk callerID 333-555-1100
I want the caller ID from x107 to x106’s cell phone in his followme list to be 333-555-1107, so x106 knows it is x107 calling when he answers his cell.

Thoughts anyone?

If defaults settings are configured for the Follow-me’s CID, when 107 call’s 106, you should get 107’s outbound CID transmitted to the cell phone of 106.

If you are not getting that, it sounds like you may have some other CID setting overriding that behavior somewhere, such as a fixed CID value for 106’s followme (vs. an outside calls fixed CID value which would not override 106’s CID in this example).

Ah, You hit the nail on the point that I didn’t give nearly enough information to make my (probably outside of the normal) goals clear…

x107 has no outbound caller ID, and therefor gets set by the trunk, which is the intended goal for ALL CALLS x107 makes to the world… however, I want to create a special exception for calls to x106 from x107, so it would use a different external caller id when routing to the followme. (ideally, rules for any internal->internal call)

I did have one other thought of a way to accomplish this (out of the norm) goal… and that would be to overwrite the default followme dialplan, with a custom one that uses an AGI script to determine if the callerID should be manipulated based on internal->internal and uses the rest of the default (copies) followme dialplan if it doesn’t hit this rule login, but that sounds as bad as the multi-trunk concept.

x106 has the default External CID Configuration so the CID is not fixed there anywhere.

So, Yes, x107’s caller is using the trunk configuration, which is how it would be desired for ALL except internal->internal calls.

Does that help clarify my challenge?

not knowing your entire setup, it’s not clear what your overall system goal is.

You could set an outbound CID value and create a standard route for 106 (and any other extensions requiring this behavior) that overrides the outbound CID value to get the current effect.

You could then create another route that requires a prefix to dial, that does not override the outbound cid value, and you could use that prefix in the followme.

The effect you will get is the overriden Outbound CID value with normal calls, but 106’s CID value on Follow-ME calls dialed with the prefix.

Well, that would do it…
Maybe this might be easier

If I setup an additional outbound route, with nothing as prefix (just put it at the top of the list), and in the route setup each of the destination mobile #'s and the respective caller ID’s I want to use this route, and setup particular CID for… Then (for example) any call from the boss, would get a particular callerid to any of those mobile #'s, the others would fall though to different routes. SWEET…

I tried it, and I think it would work, although I may have stumbled on something else odd/wrong… Followme is working for external->extension->followme correctly… however an internal->internal is NOT trying followme. (I even just removed what I put in to be sure that wasn’t affecting it) and it’s not.

Tailing the asterisk/full log file, shows internal->internal ringing the extension, then going to voicemail directly, not even trying the followme… This used to work, although a few weeks ago I did upgrade my freepbx… and may not have noticed it stopped somewhere along the way… is it possible I have a new setting I have to put somewhere?

extension to extension will use the follow-me setting if there is one and it is enabled.

If it is not working, then something is not right on your system.

This is accomplished because ext-local should come after ext-findmefollow in the include list of from-internal-additional generated in extensions_additional.conf.

Of course if the user’s follow-me is disabled then it will skip the follow-me settings.

Ok, so I should beat someone else for playing with custom contexts! Now followme is right, and with the new outbound route, it does what I want.

Now just some testing and config tweeking with the new singular outbound route, and my issue should be resolved.

Thanks Philippe, you are awesome.