Custom Extension Dial Option not working with PJSIP driver

freepbx
Tags: #<Tag:0x00007f702c916d80>

(Mitch Mitchell) #1

This weekend I changed all my SIP drivers to PJSIP driver and everything works with one exception.

I have custom extensions that act as proxies for real extensions on a key system that is connected to my FreePBX box through an SPA-3102 adapter. I created a trunk “panasonic” connected to the SPA-3102 that is physically wired to one of the key systems extensions so that dialed numbers pushed through that trunk look like internally initiated calls to the key system. Thus calling extension 103 on the key system, the FreePBX user would dial custom extension 2103 and it would connect to the key system extension as though it was dialed from another key system physical extension (which it actually was).

To do this before, I set the custom extension dial option to “SIP/panasonic/103” which dialed extension 103 on the key system from its extension 116 which was wired to the SPA-3102.

Now with the PJSIP driver handing the “panasonic” trunk the dial option doesn’t seem to be valid. I get a warning that this can only be used on a SIP channel. I tried “PJSIP/panasonic/103” but Asterisk complains that it can’t reach the invalid SIP URI 103 and asks if it is registered.

In both drivers this produced a dialplan line that is a hint. I’m thinking the syntax to shove some digits through the panasonic trunk to dial the extension on the key system is simply different now but I have no idea where to start looking.

Any thoughts?


(Joshua C. Colp) #2

The format for PJSIP would be “PJSIP/103@panasonic”.


#3

Instead of the virtual extensions, just use an Outbound Route with
prefix: 2
match pattern: 10X
pointing to the Panny trunk (assuming it has 100 through 109).


(Mitch Mitchell) #4

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Mitch Mitchell) #5

I got it working to a degree – I had to change the Line 1 port to 5061 so that calls to the PSTN would at least attempt to go through. Something on the SPA-3102 isn’t handling the call correctly yet but I’ve made some progress.

Joshua – your note about the way to specify the PJSIP dial was spot on.

Stewart – I do have an outbound route set up like that. Now I’m wrestling with the call handling on the SPA-3102, the custom (not virtual) extensions work to at least reach the SPA.


(Mitch Mitchell) #6

I found the answers here in this post:

https://community.freepbx.org/t/sipura-linksys-3102-pjsip-as-device-extension/67164/5