Custom Device Hints

Hi all,

here my system:

Asterisk 1.4.26.3
FreePBX 2.6.0RC2

function DEVSTATE installed

amportal.conf
USEDEVSTATE=true

I can’t use blf from my snom (daynight,dnd,followme) and in cli (core show hints) I see always:

*[email protected] : Custom:FOLLOWME110 State:Unavailable Watchers 0
*[email protected] : Custom:FOLLOWME104 State:Unavailable Watchers 0

*[email protected] : Custom:DEVDND110 State:Unavailable Watchers 0
*[email protected] : Custom:DEVDND104 State:Unavailable Watchers 0

*[email protected] : Custom:DAYNIGHT0 State:Unavailable Watchers 1

Why the state is always Unavailable?

Thanks

I think that the extensions 110 and 104 have the phones set to DND (Do Not Disturb). And of course, since it is not available to a direct call, it would not be available to DND. And the DAYNIGHT extension toggle is not really an available extension.

But to test this I put my 212 extension on hold. It did not go unavailable until I tried a call to it. My FollowMe extensions don’t show up at all.

-= Registered Asterisk Dial Plan Hints =-
[email protected] : SIP/225 State:Unavailable Watchers 0
[email protected] : SIP/223 State:Idle Watchers 0
[email protected] : SIP/219 State:Idle Watchers 0
[email protected] : SIP/218 State:Idle Watchers 0
[email protected] : SIP/214 State:Unavailable Watchers 0
[email protected] : SIP/213 State:Idle Watchers 0
[email protected] : SIP/212 State:Idle Watchers 0
[email protected] : SIP/209 State:Idle Watchers 0
[email protected] : SIP/208 State:Idle Watchers 0
[email protected] : park:[email protected] State:Idle Watchers 0
[email protected] : park:[email protected] State:Idle Watchers 0
[email protected] : park:[email protected] State:Idle Watchers 0
[email protected] : park:[email protected] State:Idle Watchers 0

  • 13 hints registered

Thanks for your reply.

The phones (extensions) 110 and 104 (only 2 examples) are not set to DND.
With core show hints I can see the idle state (110 and 104) and watchers.

I’ve solved daynight hints (maybe…) simply by delete and restore daynight (*280) settings. Now I can see:

*[email protected] : Custom:DAYNIGHT0 State:Idle Watchers 3

And all seems to work good (about daynight)