Custom destination

Dear Team,

I have installed freepbx 14 with asterisk 14 in centos 7 Server.

And i have created Queue called 123456 and created some sip and iax extensions.

Also created the Custom extension 50001 and routed my context and executed my dial plan ,then routing to queue 123456

when am calling from sip extension to 50002 , its getting routed my context and executed my dial plan ,then routing to queue 123456. when routing to queue am not able hear the voice…

the same when am calling from IAX extension to 50002 ,its getting routed my context and executed my dial plan ,then routing to queue 123456. and am not hear the voice…

When dialing the same directly the queue number 123456 from soft phone its working fine…

also i have dialed from sip extension to another sip extenison am able to hear the voice with out any problem.can any one help me on this ?

below is the log from sip extension to custom number 50002

Executing [[email protected]:3] Goto(“SIP/40029-0000014e”, “customdests,dest-11,1”) in new stack
– Goto (customdests,dest-11,1)
– Executing [[email protected]:1] NoOp(“SIP/40029-0000014e”, “Entering Custom Destination testcall,s,1”) in new stack
– Executing [[email protected]:2] Gosub(“SIP/40029-0000014e”, “testcall,s,1()”) in new stack
– Executing [[email protected]:1] Set(“SIP/40029-0000014e”, “MONITOR_EXEC=mv /var/spool/asterisk/monitor/^{MIXMONITOR_FILENAME} /home/phonon/media/^{MIXMONITOR_FILENAME}”) in new stack
– Executing [[email protected]:2] NoOp(“SIP/40029-0000014e”, ", 1531485472.350 ") in new stack
– Executing [[email protected]:3] Queue(“SIP/40029-0000014e”, “123456,s,1”) in new stack
– Started music on hold, class ‘default’, on channel ‘SIP/40029-0000014e’
– Stopped music on hold on SIP/40029-0000014e
– Hold time for 123456 is 0 minute(s) 0 seconds
– Told SIP/40029-0000014e in 123456 their queue position (which was 1)

The /var/log/asterisk/messages log will tell you what is happening. I recall hearing something like this in a similar sequence, but I don’t recall what (if anything) we recommended for this.

Of course, the obvious place to check is your NAT configuration on the extension and in the extension’s configuration in FreePBX. Make sure that both ends of the conversation are set up correctly.

Dear Team,

I have check in both condition with Nat=yes and Nat=no also result remain same.

And also when am dialing the Queue number directly am able to hear the welcome music and hold and all other voice…But when dialing from dialplan (121212 is the queue number) as exten => s,1,Queue(121212)

am not able to hear the voice or any of the prompt playing .

Can any one help on this?

Where did you check NAT? There are a couple of places. On the extension and on the SIP settings for sure.

What do your logs say?

As Dave mentioned audio issues are usually NAT related, especially when you are seeing it intermittently working. If that is the problem, the root is the RTP packets are not reaching the endpoint.

I have checked the nat on extension and advanced sip settings…

Are you seeing failure on your logs? Or does it appear the same as when you are hearing audio? If everything looks good from the logs, you might need to look at the network and see what is happening to the RTP (voice) traffic.

logs are same.nothing is there from logs to find

Then the answer most likely is in the network traffic. If the call is setting up and maintaining, your SIP signaling is working, but what is happing to the traffic on ports (10000-20000)?

Network-wise what is between your FreePBX box and the IAX extension? Are they on the same subnet?

Another test you could do is to temporarily disable your firewall and see if the connection works. That would tell you if the FreePBX server is blocking.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.