Custom dahdi config freepbx keeps overwriting!

I’ve got my /etc/dahdi/system.conf and /etc/asterisk/chan_dahdi_groups.conf the way I want them but Freepbx keeps overwriting them. I can’t make changes in GUI to give me the appropriate conf files.
I have Digium PRI 4 port card with ports 1 and 2 going to PSTN and ports 2 and 4 going to Rhino channel bank (Rhino support can’t help with Freepbx overwriting files)
These are the contents of files I want:

/etc/dahdi/system.conf

span=1,1,0,ESF,B8ZS
span=2,1,0,ESF,B8ZS
span=3,0,0,ESF,B8ZS
span=4,0,0,ESF,B8ZS
fxoks=49-72,73-96
bchan=1-23,25-47
dchan=24,48
loadzone=us
defaultzone=us

/etc/asterisk/chan_dahdi_groups.conf

; [span_1]
signalling=pri_cpe
switchtype=national
pridialplan=national
prilocaldialplan=national
group=0
context=from-digital
channel=1-23

; [span_2]
signalling=pri_cpe
switchtype=national
pridialplan=national
prilocaldialplan=national
group=0
context=from-digital
channel=25-47

; [span_3]
signalling=fxo_ks
switchtype=national
pridialplan=national
prilocaldialplan=national
group=1
context=from-internal
channel=49-65
immediate=yes
context=house
channel=66-72

; [span_4]
signalling=fxo_ks
switchtype=national
pridialplan=national
prilocaldialplan=national
group=1
context=house
channel=73-96
immediate=no

Can someone help me configure these settings via Freepbx interface or an alternate method to set this config (short of running a script on schedule to overwrite Freepbx generated files)

Thanks in advance!

Disable the dahdi helper module in module admin.

  1. You can disable the module
  2. You can use _custom.conf files for things you wish to put in place
  3. You should not have 2 spans as a primary timing source.

Disabled module, thanks guys!