Custom CID not being passed to PSTN in a P asserted Identity configuration

Hi all, I am trying to get the custom CID which I set in outbound route to display instead of the trunk username when I make call. Whichever way I try to force the custom CLI it still displays the trunk name on outgoing calls. I am sending P Asserted Identity header

Will your carrier accept the CID you are using? Are the CID options set correctly on the Trunk?

Yes I set the CID in Outbound route as well as the Trunk Configuration. But for some reason it takes the username in Trunk Configuration and sends it as CLI.

Possibly, your provider is getting caller ID from the From header. In your Trunk configuration, try setting From User blank. If that causes calls to fail altogether, put it back and we’ll try other approaches. If it fixes the problem, great. If it doesn’t change anything, leave it blank while we try other options.

Is the caller ID you are sending in the format your provider expects? For example, a London, UK number might be represented as 71234567 (if you’re in London), 02071234567, 442071234567, or +442071234567. A good bet is to look at the caller ID they send you on an incoming call, and use that format.

If no luck, please post: Who is the trunking provider? What country are you in? What country is the custom caller ID you are trying to send? What country are you calling?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.