Custom call number

Good evening everybody,

First of all, i must say that i searched all the forum(s) for an answer to this question:

My internet provider (Illad/Free) uses a voicemail system that can be called from the phone.
The key sequence is: **1 (3 keys)

I’ve tried to change the match pattern of outbound route to be able to dial this key sequence, but unsuccessfully.

I do not know what to do.

Could someone help me ?

Thanks in advance.

Chris.

Outbound routes - new outbound route

Call it whatever you like. In the dial patterns, put **1 in the match field.

Choose the trunk for your provider.

Save and apply changes.

Make sure your provider trunk configuration is not manipulating or rejecting this pattern.

Dial **1 from a phone. If you get an error condition, determine whether it’s from Asterisk or from your phone. Your phones might not allow ** as the first part of a dialed number. Some phones (especially ATAs) use this sequence as the beginning of an internal feature code or setup code.

That was the procedure that i tried before be unsuccessfully.
Moreover, the phone is able to use it, since my previous installation of Asterisk was using this kind of extension and was working:
exten => **1,1,Dial(DAHDI/1/${EXTEN:0}) ; Messagerie FREEBOX.

My phone is a cisco 7971.

Is there a way to create this king of match in the dialplan of freepbx. ?

Thanks.

Chris.

To figure out what is going on, ‘core set verbose 6’ at the console and try your call, then examine the Asterisk full log (/var/log/asterisk/full or install the Asterisk Logfiles module in FreePBX).

I’ve done what you adviced and here is the result:

  -- Starting simple switch on 'DAHDI/3-1'
-- Executing [**[email protected]:1] Pickup("DAHDI/3-1", "1&[email protected]") in new stack
-- Executing [**[email protected]:2] Hangup("DAHDI/3-1", "") in new stack

== Spawn extension (from-internal, **1, 2) exited non-zero on ‘DAHDI/3-1’
– Executing [[email protected]:1] Hangup(“DAHDI/3-1”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on ‘DAHDI/3-1’
– Hungup ‘DAHDI/3-1’

Why does freepbx hangups ?

Strange …

Chris

Go into Feature Codes and disable or change the feature code for “Directed Call Pickup” to something other than **.

Thanks very much, now it works.
Chris.