CRM upgrade dependency on Zulu module version 14.0.3.31.6 or higher

My Module Admin Updates page says Customer Relationship Management needs upgrading from 13.04.32 to 14.0.1.2 but to do that it says

“Missing Requirements: Zulu module version 14.0.3.31.6 or higher is required, you have 14.0.3.31.3”

How do I upgrade Zulu to 14.0.3.31.6 when it tells me I already have the latest version?

You need the edge version of Zulu:

fwconsole ma upgrade zulu --edge

edit - fixed typo in zulu

Thanks for the reply. The response to the command you provided is:

“Zulu is not a locally installed module, unable to upgrade”

It is installed, and cannot be uninstalled unless I also uninstall sangomacrm.

fwconsole ma upgrade zulu --edge

little z

fwconsole ma install zulu --edge

Unable to install module zulu:
 - Cannot find module
1 Like

Absolutely brilliant.
I forgot about Edge.
fwconsole ma upgrade (or install) zulu --edge did not work, of course …but --edge was definitely the key to making it work.
try:
fwconsole ma downloadinstall sangomacrm --edge

That should also download and install zulu 14.0.3.31.6

1 Like

fwconsole ma downloadinstall sangomacrm --edge

That worked! Thanks.

1 Like

Outstanding ! Thank you …

I am experiencing the same issue and all of the solutions you suggested did not work.

[[email protected] ~]# fwconsole ma downloadinstall sangomacrm --edge
Edge repository temporarily enabled
No repos specified, using: [standard,extended,commercial] from last GUI settings

Downloading module 'sangomacrm'
Processing sangomacrm
Downloading...
 3787792/3787792 [============================] 100%
Finished downloading
Extracting...Done
Download completed in 7 seconds
Unable to install module sangomacrm:
 - <strong>Zulu</strong> module version 14.0.3.31.6 or higher is required, you have 14.0.3.31.3
Updating Hooks...Done
Resetting temporarily repository state

Run the following before upgrading sangomacrm

fwconsole ma upgrade zulu --edge

@lgaetz Any indication of when this dependency issue will be able to be resolved without the use of edge modules?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.