Critical system error - new distro install

I’m trying to install a new distro SNG7-FPBX-64bit-1707-1
The distro completes but I keep getting

unable to generate MOTD.
The /usr/sbin/fwconsole fire is not accessible.

You are likely to experience significant system issues. (no sh1t)

Is this because I didn’t have internet when the distro installed?

You need to have internet when the distro is installed.

how do you handle needing to set a static IP address when installing the distro?

That is a pain is the a. But I do understand why it’s done this way.

But on the good side. I did want to create a private management network with VPN access in my data center.
DHCP server = Done
VPN server = Done
Private Network = Done
Cloned my new Distro install = Done
New Client Distro installed and doing upgrades.

I do agree with the slideshow when you do an install. FreePBX is much better when it’s hosted. :slight_smile:

So, having a similar issue here, but with SNG7-FPBX-64bit-1710-1 distro. I’m getting exactly the same error when I log in.

The PC is connected to the network, and I know it’s working correctly (was running windows on the internet fine until I did a clean USB install of the freepbx distro).

lspci shows the following ethernet device:
00:19.0 Ethernet Controller: Intel Corp 82579LM Gigabit Network Connection (Lewisville) (rev 04)

ip addr shows 2 interfaces:
2: eth0: (BROADCAST,MULTICAST) … state DOWN …

No IP address is being requested from or assigned by my DHCP server.

I thought it might have been due to a conflict with my PCIe TDC400P card, so I removed this and re-installed. Got exactly the same error.

Any idea why the network is not coming up correctly?

Need to get your hardware correct before you try to install this distro.

This is plain vanilla Dell Optiplex 990 PC with no extra hardware installed. Not sure what what would be wrong with this setup???

When the distro completed you do get a login.
when you run ip addr I bet you don’t have an IP address.
ifup eht0 should get it to work.

Trouble is your PC is not compatible with the distro.
Maybe a new nic card would do the trick.

Yes, I get a login. That’s how I was able to run the lspci & ip addr commands.

I just installed a clean version of CentOS-7-x86_64-Minimal-1708 to see if I could get the network interface working. During the install (at the same point the root password prompt is given) I get the option to enable the network card. It worked fine when I did this.

When I installed the FreePBX distro, I very briefly saw the same menu screen for enabling the network card, but that screen then disappears, and you’re only left with the a minimal screen with the only option to set root password. I think the ifup command may well work. I suspect this does the same as the enable option on the CentOS install. I’ll need to re-install the FreePBX distro to check.

Just noticed that there is an advanced option in the FreePBX install that brings up the screen to enable the network interface & allow me to change other options (like language, timezone etc). Just trying that now. FreePBX is currently installing. Fingers crossed…

Edit: So the install is ‘stuck’ at Installing freepbx (584/661). I never got this before, so I’m hoping it’s working better now. Looks like it might be downloading and installing stuff that it couldn’t access before.

It can take a LONG time. Sorry. On a slow machine it can be installing for more than an hour, as it has to compile a lot of things specific for your machine.

Going back to your other post:

As part of the automatic install, it enables and DHCP requests an IP on every network interface it can find. It would have been handy to get the logs, as I’m intrigued as to why it wouldn’t work. One of the things I did with the 1710 ISO is to update the Intel Ethernet drivers to support new machines. It’s obviously working, because you can enable it manually, I’m just curious as to why it missed the automatic enable.

Manually enabling the interface got it working!

I can easily do an automatic reinstall and provide the necessary logs. What logs do you need?

There’s actually a command - ‘send-logs’ that posts everything to pastebin that I need, and gives you a single URL to send!

When the machine is broken, just ctrl-alt-f2 to a new window, run ‘ifconfig eth0 up’ and then ‘dhclient eth0’ to get an IP address, and then run ‘send-logs’. That’s all you need to do!

1 Like

That’s me just reinstalling it now with the default standard install options. It’s paused again at installing freepbx. I obviously didn’t notice this the first time I installed. I’ll post up the logs as soon as it finishes.

It’ll take LONGER when it has internet access, as it will then be able to download and compile everything. You may find that it just didn’t have the network cable plugged in at the right time. You can ctrl-alt-f2 right now and run ‘ip addr’ to see if it’s got an IP address.

I was also reminded that ‘send-logs’ only work in the installation environment.

Hmmm. I don’t understand this. Th interface is working with this install and is picking up an IP address. I’m doing exactly the same as I did on the first couple of installs, where the interface didn’t start. I’ll keep working it.

Well. I’m going to lay the blame squarely on the phase of the moon. Obviously your machine was being haunted!

1 Like

Just kicked off another re-install. Install is ongoing, but I’ve done a Ctrl-Alt-F2 and this time the interface appears to be up, but no ip address has been picked up.

[quote=“xrobau, post:15, topic:44851”]
It’ll take LONGER when it has internet access
[/quote]Yes. That’s definitely the case. It’s a lot quicker this time, when no IP address has been picked up.

Sounds like your DHCP server is playing up. Possibly it’s slow, or, out of leases?

It does sound like there might be a timing issue. The DHCP server is definitely not out of leases. The lease expiry setting means that it’s giving out the same IP address to this machine every time it’s being requested (even when I had windows on it previously).

Are you still wanting the logs? The install is complete. I’ve not rebooted yet. As I said earlier, Ctrl-Alt-F2 indicates that the interface is up, so I’m guessing a ‘dhclient eth0’ is all I need to do to get it active. Should I do this, so I can send the logs?

Edit: got impatient, so I did a ‘dhclient eth0’ and it immediately picked up the IP address.

Edit2: I can also SSH into the system now to pick up the logs, if you can let me know what logs I need to grab. Actually, scrub that last sentence. I can ping the computer, but connection refused to SSH!

Edit3: Ran send-logs from the Ctrl-Alt-F2 console after getting an IP address, and it’s saved the logs to