Creating a Junk Call Blocker and getting 503 Service Unavailable with OBI110 and Raspberry Pi

I am following the instructions from this website:


It uses an OBI-110 and a Raspberry Pi with Asterisk/FreePBX to create a nuisance call blocker. I have followed the instructions and even reimaged the Raspberry Pi several times but I always end up with the a situation where calling my home just rings (for the caller) and the home phone never actually rings.

I have posted a dump of the “rasp*CLI>” resulting when an outside call is placed and posted that to:


(Yes I know the password is the generic password for now)

Near the end you will see the lines:

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/813
– Got SIP response 503 “Service Unavailable” back from
– SIP/813-00000007 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)

I have talked to OBI and they insist that the problem is my setup in Asterisk. I have followed the directions for both the OBI and Asterisk, and even reset the OBI and reimaged the Raspberry Pi a couple times, but I always end up in the same place.

Also, I have tried the setup with FreePBX 2.xx and FreePBX 12, with all modules updated.

Any help would be great. If someone has created a better tutorial for this setup, I would love to hear about it too.

Thanks for any help.

Just found out that when an inbound call is made with the “nightwarning” time condition met (very late night until early morning), the caller receives the “Press One To Call” message two times in a row, which at least is something, but when the 1 key is pressed there is a busy signal.

Still frustrated. Any ideas out there?

Ok solved the problem after much head-banging and it had nothing to do with Asterisk or FreePBX. In the tutorial under OBI110 settings, it should have been:

Voice Services
SP1 Service
X_InboundCallRoute: ph (NOT LI as in instructions)