Crackling w/ S705 + EXP100 + PC


(Alex Fassas) #1

Our FreePBX works and is working, except for a recurring issue (or feature) with 2 S705 phones that will begin crackling in the audio after an unspecified period of time, usually 2+ days. The crackling audio makes the ability to listen on either the handset or speakerphone impossible.

The 2 affected S705’s are the only ones that also have the EXP100 sidecar attached (only 1 EXP100). All phones are being used in ethernet bridge mode to connect the users PC to the LAN. All LAN connections are 1Gbps, full duplex.

The affected desksets have the following physical connection:
LAN->S705->EXP100->PC
The Ethernet LAN works for the PC just fine, either before the crackling or after. We have not identified a specific causing factor to the beginning of the crackling. A power cycle of the S705 will restore things to a clear audio and working condition again.

Additionally, the EXP100’s do not follow the backlight and dimming settings of the S705 phones. The EXP100 stays lit, even when the S705 screen goes dark. All extensions are setup and managed through Endpoint Manager.

We have done no monitoring of the FreePBX SIP or RTP traffic on this issue yet. Nor have we downloaded any logs from the phones. It is mpossible to understand audio when listening to a voicemail from the phone, when it is crackling. After phone reboot, you can listen to the same voicemail and it is clear audio.

There has been no support ticket opened yet. Starting here 1st. I am perfectly willing to go the support route. GO!!

Our environment is:
Asterisk 16.6.2
FreePBX 14.0.13.24
latest module versions as of 2/22/2020
from a SNG7 Distro install
On an VMWare ESXi 5.0 U2 virtual machine.
All phones are either on the local LAN, a few connect via our own gateway VPN’s. The affected phones are on the local LAN.
The affected S705 phones:
S705 firmware 3.0.4.75, with DSP 9.0.3
EXP100 firmware 2.0.5.0

This PBX has been working great through a testing phase. Now that we have deployed all Sangoma desksets, 15 total, a mix of S705 and S505’s, with 2 S705’s with EXP100, this issue has begun regularly.


(Alex Fassas) #2

Apparently, either my original post was too long or the answer is self-apparent to some, but not to me, as there has been no response or suggestions.

The 2 affected S705’s are the only ones that also have the EXP100 sidecar attached (only 1 EXP100). All phones are being used in ethernet bridge mode to connect the users PC to the LAN. All LAN connections are 1Gbps, full duplex.

The affected desksets have the following physical connection:
LAN->S705->EXP100->PC
The Ethernet LAN works for the PC just fine, either before the crackling or after.

Is the above use of the bridged ethernet LAN to a PC supported? Could this somehow be the cause of the phone crackling audio?

I have also opened a support ticket on this. Ticket # 949047.


(Charles Darwin) #3

The Sangoma S-series phones are badly designed phones, HW and SW.
A year ago I bought a s705 and never deployed it, because it is a chinese low-quality piece.
After that I bought around 15 Sangoma/Digium D65 phones…no issues at all…best Asterisk phones ever!
On most D65 I use the ethernet bridge for PCs.


(Brian Ladd) #4

I have to 2nd this. I’ve deployed ~25 S505’s, had 5 RMA’d within the first 30 days for bootlooping, and had to pull back the rest. Completely disappointed. So much potential with EPM and Phone Apps, but the hardware just continues to disappoint.


(Alex Fassas) #5

Just a follow up for the community. In working with Sangoma support, via a support ticket, it looks like we have fixed the issue.

Sangoma had me to rollback the S705 phone firmware from version 2.0.4.75 down to 2.0.4.72. This has apparently remedied the issue with the 2 S705 phones with the EXP100 attached. These phone have not exhibited the crackling audio issue since the downgrade on 28 February, 2020, 11 days now. The issue usually happened within 2 days, each time.

On another note, YES, the ethernet LAN bridge through the phone -> EXP100 -> PC does work, just fine.

As for the comments about Sangoma S series phone build and software quality, I cannot comment. We have only been using the Sangoma S series and our experience has been just fine. We appreciate that the Sangoma FreePBX team continues to support, improve, and add functionality to the system as a whole.

In all fairness, we did have 1 issue with an S series phone, 1 out of 17. An S705 would display a flickering screen with lines on the display. We replaced the power adapter and everything was fine with the phone. Apparently, the phone really likes to have the proper power input to work properly.


(system) closed #6

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.