CPU Frequency Scaling

What CPU Frequency adjustment and monitoring tools can be safely and reliably used with the FreePBX Distro?

Any that can apply changes that will not be lost on boot?

Is it in a virty or a physical machine?

Physical machine. Intel CPU

I would be interested to know the outcome. Are you just trying to save on power consumption? I would think this setting would be updated or overwritten by the distro or updates.

I’m just trying to figure out A) if it is operating at its maximum frequency B) fluctuating via Intel speedstep depending on load, and C) if it’s stuck at its lowest frequency.

The reason for option C is that I have seen some ubuntu Linux and some FreeBSD systems stuck on their lowest multiplier and/or p-state unless otherwise programmed in the OS.

And the perceived problem is what?

…The system would be underperforming.

Then don’t do it, again what is the benefit of doing that on a critical machine?

Do you even understand what I’m after? I’m just trying to see what the CPU is up to. Geeze…

I believe I do, but do you? If you want to save 2watts on a laptop and extend the battery life by five minutes when you aren’t watching Netflix, it might be worth it, otherwise leave it off in the bios, it just isn’t appropriate for a server.

I’m not trying to save 2 watts. Like I already said, I just want to see what the CPU is up to. It’s a laptop that I’ve repurposed as a PBX. There isn’t an explicit option for Speed Step in the BIOS.

If you’re not going to help me find a package to install then please butt out of this discussion.


(padding for needed characters)

How about this instead - take your inappropriate, unrelated, non-FreePBX question and entitled and disrespectful attitude someplace where insulting people will get your questions answered.

1 Like

This thread now has two flags against it from community reporting. At this point I think it’s run it’s course and thus I am locking it to prevent a flame war. Please control your responses. If you have nothing nice to say then don’t say anything at all. I am especially bad at this so I am one to talk however I can’t see this thread going in any good direction any longer.

I have found a partial solution to my problem. I have not fogured out yet how to make it persistent on boot.

  1. yum install cpupowerutils.x86_64

  2. modprobe acpi_cpufreq

  3. cpupower -c 0 frequency-info and then cpupower -c 1 frequency-info

Core 1 as i suspected was getting stuck at 800MHz even when I put the system under full load. The default governor was set to “userspace”.

  1. cpupower frequency-set -g performance

This forces both cores to run at 2.53GHz however, I do not believe this is persistent on boot. I will have to test this later tomorrow night when the PBX is not in use at all.

So I found documentation on how to make “modprobe acpi_cpufreq” persistent but there does not appear to be an “rc.modules” file in /etc for the FreePBX distro.


rc.local is present but rc.modules would load the drivers earlier in the boot process.

Is there a way to enable the use of rc.modules?

A file (ending in .module) in /etc/sysconfig/modules/ should do it ie /etc/sysconfig/modules/mymodule.module


“/etc/rc.modules” was used in redhat/centos 5, if your on the stable freepbx its basically redhat/centos 6.x, the alpha/beta is 7. Side note, you should be more respective of people that try to help, members that you acted rude to previously are highly respected members of the community, that being said I hope this helps and I hope you find a resolution to your problem.

1 Like