Core 13.0.110 Upgrade from 13.0.107

Today I upgraded (of course without a backup) the core module from 13.0.107 to 13.0.110 as I was notified of the update being available. However my Cisco 9971 which was previously connecting via TCP perfectly fine for the past month or two since I configured it now will no longer register. According to the module history “13.0.109: Don’t generate out transports that are invalid” which I suspect may be something to do with the issue? I have tcpenable=yes as needed for the 9971 under Asterisk SIP Settings and the extension is set to TCP for transport. Yet I get the following error now in the asterisk log.

[2016-09-01 14:02:24] ERROR[2197] chan_sip.c: ‘TCP’ is not a valid transport for ‘1001’. we only use ‘UDP’! ending call.
[2016-09-01 14:02:24] NOTICE[2197] chan_sip.c: Registration from ‘sip:[email protected]’ failed for ‘’ - Device not configured to use this transport type

Anyone have any idea? I don’t see a bug to look at details on the 13.0.109 changes other than the basic description it gave but that description certainly implies its possibly related to this?

core v13.0.111

1 Like

Woohoo its back! Thanks!

Hi All
Returned to work this morning to find all of our Cisco phones not registering. This is the error
chan_sip.c:17088 register_verify: ‘TCP’ is not a valid transport for ‘xxx’. we only use ‘UDP’! ending call.

They were working fine on Friday. Because we are using Cisco firmware 9.4.1 SR1 we have to use TCP. This has been working great for over 12 months. All of a sudden we get these errors. The following is still in sip_custom.conf
transport=udp, tcp

Any idaes???

Found and temporarily fixed the problem.

It seems this latest version of the sip_settings module ( ignores the Transport setting in the extension UI (Advanced tab), and instead always writes transport=udp into sip_additional.conf.

Temporarily fixed by overriding in sip_custom_post.conf, e.g.

Hope they fix this soon.

Transport is written out per device. Not in sipsettings. Regardless. This was fixed in the latest core module.

This does not appear to be fixed.
Im using core 13.0.111 and the extension settings in sip_additional.conf still have transport=udp when in FreePBX>Aplication>Extension>Extension number>Advanced>Transport is set to All-TCP Primary.

13.0.111 fixed it for me and I am now running 13.0.112 with no problems.

Advanced settings needs to have tcp enabled as well