Contact URI causing incomplete SIP calls. Where can I set this? (I have it working fine on a test PBX!)


We have a really weird issue going on here and I am stumped as to what could be causing it.

Please can someone help me.

I always setup a PBX with 2 NICs (one for management and provisioning and the other for the SIP provider connectivity)

I have set up a SIP trunk on my test PBX and it works fine on the test PBX (without all modules etc)
With another IP on the range I have tried to setup the production PBX with SIP connectivity to the supplier, however calls are failing.

On the one that works, the external interface is shown in the contact URI, however on the production server, the contact URI is showing the internal management address.

This is causing problems so that when calls are made, the SIP provider is using the contact URI to send the traffic back and causing the PBX to think the call is not answered.

So now to show the wiresharks:

The working one:

The one that I cannot get to work:

Now I will show the SIP trunk advanced settings on the working and non working (they are set both the same)

Non working (ignore the fact the ips are different, we have a /29 subnet)

Working one:

I thought it was something weird with NAT, but NAT is not enabled in the advance settings.

I have checked the pjsip.endpoint.conf files back end and the settings look exactly the same. The registration looks fine on both PBXs and all settings are now matching.

I would switch everything over to the test PBX but I have so many commercial modules that I rely on in the production environment.

Please can someone help me? It is like the contact URI set in the PJSIP trunk settings is not applying.

I could be NAT. Even though you are connecting “more or less” directly, you need to make sure that the port is set with the correct IP address and that the SIP setting (in Advanced Settings) are correct for your configuration.

Thanks… I have tried setting the external interface to the address with no avail.

Calls go through, but when I answer, the reply from SIP is to the 10.11 address so the PBX does not get the response packets.

I have even paid for Sangoma support to identify the issue and after a 2 hour session, I am no further forward with this being escalated internally.


@a0429 Pls check below link.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.