Contact Rewrite Bug?

Freepbx 14, all modules and updates to date as of 4/20. Contact rewrite still gives phone a local IP and our systems are in the cloud. To fix, we have to set to “no”, apply config. Set back to yes and apply config again. Restarting asterisk did not work either.

Can you explain exactly what you are seeing and what you are expecting?

All phones get a local IP address which causes them to to register to the PBX in the cloud. We had this issue in the past, but freepbx was setting the rewrite contact to NO on an update. The only way I could address this was to set to NO, apply config, and back to yes on each extension and reboot the phones. I tried restarting asterisk first which had no affect

Define “get a local IP address”. The Contact Rewrite option for Asterisk rewrites the incoming Contact from a SIP device to the actual source IP address and port.

example. For our setup it should be similar to:

101/sip:[email protected]:15159;x-ast-ori c1c05fa346

Contact rewrite was doing this:

101/sip:[email protected]192.168.1.101:15159;x-ast-ori c1c05fa346

You can check if the option is set by executing “pjsip show endpoint 101” in the Asterisk CLI. If the option is set and it is still not working I’d suggest getting a packet capture to examine the actual traffic.

I can’t repeat it now that I’ve fixed it. This was a known issue before. I even found threads on the exact same issue, and people were restarting asterisk to fix it.

I’ll have to try next time. Thank you

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.