Contact 102/sip:[email protected]:5060 is now Reachable

There is some way to change the port in which this phone is registered, this is a conflict with an ATA that I have in the same location.

I have Asterisk 14.7.6 with FreePBX 14.0.2.18 in VPS

It is an IP phone with the extension in pjsip, the ATA is port fxo in chan_sip.

Thanks

Yes there is. In fact, there are ways to change all of the SIP ports. Your message isn’t clear on which of the (at least four) ports you are trying to change. Each is set in a different screen.

Yes sorry.

I need to change the port for extension 102, it always registers with 5060.
I need to force it to use another port.

Aor: 101 3
Contact: 101/sip:[email protected]:5409 040c225eda Avail 54.293

  Aor:  102                                                  3
Contact:  102/sip:[email protected]:**5060**              1a8ece0253 Avail        54.535

  Aor:  105                                                  1
Contact:  105/sip:[email protected]:57481;ob           11fb47d6cf Avail        73.545

I can get from freepbx to use another port the extension 102?

I’m even more confused now.

Port 5060 is your inbound signaling port on your Asterisk server. Port 5060 on your ATA is different - it’s on a different server, so the port number should be irrelevant.

You can change the inbound signaling port for Asterisk in the SIP Settings page. PJSIP and ChanSIP are already using different ports, so change one, the other, or both to new addresses.

If you just want to change the one for Extension 102, you should be able to change that in the extension settings (IIRC).

If the “view” of the two ports from the Internet (through a NAT router, for example), you can pick any port number and ‘redirect’ it in your firewall/router. Then the two 5060 ports are separated by the router and by their IP addresses.

Remember, the port number is only for listening on a specific server. Every device in the system can use port 5060 as long as everyone knows who they want to talk to. When you set the “outbound” port number, it has to match what the machine you are talking to is expecting.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.