Connection Problems (2 Trunks, Same VOIP-Provider, Same FREEPBX-System) / Phones ringing but no connection sp

Hi all,

I have set-up a FreePBX-Server on a vServer (installed with FreePBX-Distro 6.12.65) so that it is reachable from all phone-sites for the whole family.
So we have different trunks with the same VOIP-Provider ( on the same FreePBX-System.

Until some weeks ago everything has worked correctly if someone has called the so called “Long-National-Number” the call went out from trunk1 and came back via trunk2 on the same provider.
(I know this ist not really a good set-up cause these calls could be dealed intra-FreePBX but everything has worked as expected until now.)

[deleted as FreePBX got hacked]

Since about 14 days the phones on both ends are ringing but the parties could no hear each other and the call gets aborted fast after call is answered. This seem to happen only for this provider (easybell) if both trunks are located at this provider. Calls coming and going from and to outside (other providers trunk on the same FreePBX-System as well as completly external calls [e.g. mobile phone]) are working normal!

If you use the extensions to call each other than also everything works fine.

I havn`t changed anything big in FreePBX; just started to use Asterisk Phonebook Module and CID Superfecta to get name to numbers which call regularly.

Today I made the biggest change to the System: I updated the FreePBX-distro from 6.12.65 to 10.13.66; but the problem occured before this update.

The latest log of a call not working is:
[deleted as FreePBX got hacked]

Is there any solution for my problem?
Additional question (for workaround; if there is no solution): Is it possible to rewrite a called number of “0893XX9230” to the extension “230”; so that the users could keep calling the normal “Long-National-Number” but the call will be routed intra-FreePBX?

Best regards,

Sure, just use misc destination and misc applications to set up a ‘feature code’ that is the same as the long number and map it to an extension.

@mulderlr: Thank you for this workaround-hint. This works as expected.

Are there any hints why the “normal way” has stopped working?

Best regards,

Not sure. It could be a NAT issue on your PBX, it could be a carrier issue, it could be a config issue, etc.