Connecting phone behind NAT to FreePBX behind NAT

I have a Polycom VVX410 with UC 5.7.1 connecting to Asterisk 13.19.1. Both are behind NAT. The FreePBX server has port forwards for SIP and RTP, and they are confirmed working with a Zoiper softphone.

When connecting the Polycom, the phone will REGISTER momentarily with PJSIP, but then the following show up in the Asterisk logs:

[2018-07-18 18:14:54] VERBOSE[20697] res_pjsip/pjsip_configuration.c: Contact 914384/sip:[email protected]:5060 has been created
[2018-07-18 18:14:54] VERBOSE[20697] res_pjsip/pjsip_configuration.c: Endpoint 914384 is now Reachable
[2018-07-18 18:14:57] VERBOSE[20697] res_pjsip/pjsip_configuration.c: Contact 914384/sip:[email protected]:5060 is now Unreachable. RTT: 0.000 msec
[2018-07-18 18:14:57] VERBOSE[20697] res_pjsip/pjsip_configuration.c: Endpoint 914384 is now Unreachable

Doing some tcpdumps on both the PBX and the router on the remote side shows that there’s a conversation taking place between the phone and the PBX, but when the PBX requests OPTIONS from the phone, the Polycom responds twice with an ACK, and another 2 times with “403 Forbidden” but none of the phone responses reach the PBX side. I can’t figure this out, especially since Zioper is working but a Polycom isn’t.

Just wondering whether this has got anything to do with NAT on the Polycom device where NAT should be disabled as both Polycom and Asterisk/FreePBX are behind your firewall. Just a thought.

Check which port the Polycom sends the responses to.
It might be your chansip port if you have that enabled.

I have had issues when converting chansip to pjsip or the other way round, options messages would be sent to the wrong port.

The problem in the end was using NAT port translation instead of forwarding the actual port 5060. I created a new PJSIP transport on the port I wanted and forwarded that directly, and this solves the problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.