Connecting 3com 3102 A / B or 3101 A / B Phones to FreePBX

Good Day,

I am new to the FreePBX community, I have have configured incoming and out going trunks and am able to make internal and external calls with a Polycom IP331, and Eyebeam 1.5.

We are running a 3Com VCX version 7.1.14c, and it is currently working, we use the 3Com 3101 and 3102 phones to call via the VCXs.

We want to use our current 3com phones to connect to FreePBX.

We use the VCXs to boot the phones, and then we modify the “primary server” to be that of the FreePBX server, and the dialing domain to be the FreePBX. However when I try and register I get an error on the phone stating “invalid password”

On doing a tcpdump on FreePBX I can see the phone trying to register with FreePBX however I am not seeing traffic coming back from FreePBX

I am running FreePBX 2.10.1.1;Asterisk Ver 1.8.15.0

FreePBX Server IP --> 10.4.3.117
Phone IP --> 10.4.8.88 -->extension 9793
SIP settings:
External IP 10.4.3.117
Local Network 10.4.3.0 / 255.255.255.0
Local Network 10.4.8.0 / 255.255.252.0 (the Polycom also sits and this network)

You can find the wireshark trace here: https://dl.dropbox.com/u/51992808/3com3.pcap

I should mention that we have gotten the 3Com phones to connect to a Front Range IP Call Center.

Any assistance would be greatly appreciated.

Kind Regards

Michael Hayes

Your phone:-

Phone IP --> 10.4.8.88 -->extension 9793

is not in :-

Local Network 10.4.3.0 / 255.255.255.0

try 10.4.0.0 / 255.255.0.0

Applogies, I should have formated the post better I included under local networks:

10.4.8.0 / 255.255.252.0 (the Polycom also sits and this network and works)

I shall however give it a try. Thanks I shall let you know.

Cheers

you will need to have a route to that network also. or change your eth0 subnet to match

Sorry I got the same error. Thanks for the input though

Cheers

Mike

Hi,

We have routes setup on our network so those networks can talk to eachother.

Cheers

Apparently not completely.

from the asterisk cli, try

sip set debug ip n.n.n.n.n

I see what you are saying, when I run run the debug I do not see the phone registering.

I have moved the Server onto the 10.4.8.x / 255.255.252.0 network and still am not able to connect to it via my 3com phone. I am still able to connect with a polycom (polycom ip 10.4.8.226 / 255.255.252.0) and eyebeam (10.4.3.20 / 255.255.255.0) still. There must be something in the 3Com phone (10.4.8.88 / 255.255.252.0) that is not allowing me to connect to the server.

It is strange that I can connect from the polycom but not the 3Com, but then again the 3com is a brick without the vcxs.