This message is on my WEB page
That I am not using the correct PHP version
Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.4.0". You are running 5.6.40-57+ubuntu18.04.1+deb.sury.org+1. in /var/www/html/admin/libraries/Composer/vendor/composer/platform_check.php on line 25
But here you can see that I do use version 7.4
You are running as root and as such your php version will be
ls -l $(which php)
presumable resolving to php7.4
but apache2/httpd is still being told to load php5.6
Why would you want to ‘cd’ to php ?
ls -l /etc/alternatives/php
And you webserver is always ‘on’ whatever user you tell it to be. . . But that’s not the point, the way you set up your webserver includes telling it what modules to load, currently you are telling it to load php5.6. Fix that and your problems will not be the same.
I have already set the default version to 7.4
sudo update-alternatives --config php
It’s probably something to do with the composer. What raises my concern is that this happened after I updated the fwconsole from version 14 to16
that does not change the module your webserver loads.
This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.