Confusion between Digium Phones module and Endpoint Manager Commercial (RESOLVED)

I am bringing up a new FreePBX 13 distro.
I have purchased and installed the Commercial Endpoint manager.
We are trying to use Digium D50 and D70 phones.

When I initially tried the setup, the Digium phone would not find the server.
After reading posts, I installed the DPMA and acquired the free license.
Now the Digium phones will find the server and configure themselves.

However the configuration they are using is the Digium configuration, not the EPM configuration. I don’t know how to force the phones to use the EPM configuration instead of the Digium Phone module configuration.

My question is twofold:

Should the DPMA be loaded? If not, how can I make force the Digium phones to see the EPM configuration?
If it should be, then how do I get the EPM configuration to become active.


The Digium Phone module is a standalone configuration tool for the Digium phones that does not require EPM. If you have a mix of Digium and other phones, you should be able to operate both at the same time without any conflicts.

EPM can also support configuring Digium Phones directly, but there is a different (option 66) procedure you must use to get the phone bootstrapped onto the EPM configuration instead. When using this option, you do not need to have the Digium Phones module licensed or installed.

Thanks sgriepentrog - I’ll go down the option66 path. It will be a couple of days before I can try it.

I appreciate the reply.

So, I have found information about option 66 for getting configuration files to the phone via tftp. However Digium phones don’t seem to support TFTP. Does endpoint manager not support the sip based configuration that digium phones use as their default?

After re-reading the End Point Manager documentation regarding Digium phones, it seems that all is required is to factory reset the phones and you are good to go. No other configuration is specified in the documentation unless I am missing it somewhere.

I have tried forcing the phone to boot via http with the ip address of the server and the configuration port . I get a brief error message saying that the phone can’t find the configuration files.

Still puzzled. The DPMA based configuraiton works fine. I have removed the DPMA module and the phones still don’t see the EPM configuration files.

Any thoughts??


Got it working - Here are a few notes for those trying to get Digium phones working with the Commercial EndPoint Manager.

FreePBX 13.0.158
Centos 6.6

I did have to enable the DHCP Code Option 66

  • here is a link to a document that helped. Digium Provisioning

  • 2 lines added to the /etc/dhcp/dhcpd.conf file. see the document for placement examples

option boot-server code 66 = string;
option boot-server “”;

After resetting the phone to factory default and setting up the extension in Endpoint Manager, the phone then had two configuration options. The first was my DPMA server, the second being the DHCP Code 66 server.

I had to disable the DPMA server in order to have the phone use the EPM DHCP configuration settings. I didn’t see anyway to force the DHCP option to be the default.

My initial challenge is that I was leaving the :83/ off the end of the dhcp boot-server string. 83 being the provisioning port that I was using in Admin->System-Admin->Port-Management

Hope that helps.

1 Like

Hi, sorry to revive this old topic, but I’m trying to do this and I would really appreciate some help! :slight_smile:

Currently FreePBX gives every impression that it has ‘sent’ a configuration to the D50 phone, but when the phone reboots, it doesn’t take on any new settings.

Through reading various posts (so confusing with all the changes over the years and standards coming and going!) my current working theory is that because I haven’t made any changes to my network’s DHCP, the phone isn’t able to ‘find’ my EPM server??

If I modify /etc/dhcp/dhcpd.conf ON THE FREEPBX SERVER to reflect

option boot-server code 66 = string;
option boot-server “”;

then if I reset my phone to factory, I should then be able to delete it from the FreePBX GUI EPM extension mapping, RESCAN in EPM to find it again, it should then display a code 66 server ??

Basically all I’m wanting to setup is visual voicemail and BLF stuff…