Configuring WiFi and BLF on GXP1760w using EPM not working

I’m not having success configure the gxp1760w wifi settings using the epm. I connect it to ethernet to get the initial config, and the phone does provision and register with the server. But the wifi and other button settings do not come through. I found this issue tracker: [FREEPBX-16781] EPM 13.0.113 and GXP1760W provisioning - Sangoma Issue Tracker which appears to be the same problem as I’m having, and it hasn’t been solved yet. Except that my blf keys don’t appear to be configuring properly either. I think this whole template needs a makeover.


I’ve dug a little deeper into this bug, and the VPK problem appears to be this: The keys 4-6 aren’t receiving the proper “type” of line. The endpoint manager says BLF, but in the phone, lines 4-6 show as normal line keys. I don’t know if this helps narrow down any problems. But I hope someone is looking into this.

Edit 2:

Under known limitations, I found this:

BLF’s on line keys do not work or update. They do get set in the gui. This is a problem with Grandstream firmware

Is this related to the problems I’m experiencing? I tried changing the line type to other options as well, and they don’t seem to work either. I’ve definitely had success doing this with my gxp2170s, it’s strange that it wouldn’t work on the gxp1760w. I noticed in the issue tracker that @tm1000 had started making some changes back in March, but I can’t see what the current status is.

the 1760w is not listed as supported:

You may have limited success attempting to use the 1760 template, but I wouldn’t expect it to work perfectly. Additionally, there have been recent fixes published for supported GXP phones, so you may benefit from getting the latest edge version:

fwconsole ma --edge upgrade endpoint

It appears I’m already on the edge version. It’s a bummer this won’t work. Is there any way for me to create a template, or to see an ETA on when it might be added?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.