Configuring the server domain name in FreePBX GUI


(Vmayorow) #1

Hello,

I am using Asterisk 13.22 + FreePBX 14. The issue I’ve encountered is that my test SIP client is registering as sip:name @siptest.gould.co.uk, but it receives responses from sip:name @188.39.103.164 and doesn’t therefore work well.

How could I setup the domain name for outgoing SIP messages in FreePBX GUI?

Here’s my traffic. You can see that all outgoing SIP messages contain @188.39.103.164 instead of @siptest.gould.co.uk.

Client -> Server

REGISTER sip:siptest.gould.co.uk SIP/2.0
Via: SIP/2.0/UDP 192.168.1.103:46725;rport;branch=z9hG4bK51372
Max-Forwards: 70
To: <sip:231@siptest.gould.co.uk>
From: <sip:231@siptest.gould.co.uk>;tag=z9hG4bK08488578
Call-ID: 596349641856@192.168.1.103
CSeq: 2 REGISTER
Expires: 3600
User-Agent: Lumicall/1.13.1/JAT-LX1
Contact: <sip:231@192.168.1.103:46725;transport=udp>;reg-id=1;+sip.instance="<urn:uuid:62de21bd-f892-4441-b823-a0f94044e4d5>"
Supported: path, outbound
Authorization: Digest username="231", realm="asterisk", nonce="********", uri="sip:siptest.gould.co.uk", algorithm=MD5, response="**********************"
Content-Length: 0


Server -> Client

OPTIONS sip:231@192.168.1.103:46725;transport=udp SIP/2.0
Via: SIP/2.0/UDP 188.39.103.164:5060;branch=z9hG4bK0788ec4e;rport
Max-Forwards: 70
From: "Unknown" <sip:Unknown@188.39.103.164>;tag=as6814076c
To: <sip:231@192.168.1.103:46725;transport=udp>
Contact: <sip:Unknown@188.39.103.164:5060>
Call-ID: 622436d159f9135b0155655461a215b2@188.39.103.164:5060
CSeq: 102 OPTIONS
User-Agent: FPBX-14.0.13.4(13.22.0)
Date: Thu, 05 Sep 2019 09:52:27 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Content-Length: 0


SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.1.103:46725;branch=z9hG4bK51372;received=109.172.15.35;rport=48278
From: <sip:231@siptest.gould.co.uk>;tag=z9hG4bK08488578
To: <sip:231@siptest.gould.co.uk>;tag=as2f985a4e
Call-ID: 596349641856@192.168.1.103
CSeq: 2 REGISTER
Server: FPBX-14.0.13.4(13.22.0)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Expires: 3600
Contact: <sip:231@192.168.1.103:46725;transport=udp>;expires=3600
Date: Thu, 05 Sep 2019 09:52:27 GMT
Content-Length: 0

(Joshua C. Colp) #2

Can you clarify what “doesn’t work well” means?


(Vmayorow) #3

I’m using Lumicall for Android as a SIP client. It has a DNS bug and cannot resolve IP addresses. Therefore the SIP messages sent by the server are not processed (a DNS exception is raised). However Lumicall works well when SIP messages contain domain names instead of IP addresses.


(Joshua C. Colp) #4

I don’t think there’s enough configurable options in Asterisk to have every instance replaced with a domain. It’s reasonably expected for the endpoint to be able to handle IP addresses in the signaling.


(Vmayorow) #5

Thank you for your response!

Isn’t the Asterisk configuration parameter “fromdomain” related to the subject?


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.