Configuring Dundi on freepbx

I just went through half a day trying to decipher the old docs on configuring dundi. The dundi trunk page does a good job of describing what you need to do once you understand what you need to do. :slight_smile: So I am summarizing in hopes it will help someone else.

In /etc/asterisk/dundi.conf on both machines:
entityid=00:16:36:28:74:25 ; This is the mac address of the local eth0

[mappings] ;The IP is our the local machines IP. Interoffice is the name of the IAX trunk
priv => dundi-extens,0,IAX2,Interoffice:${SECRET}@${NUMBER},nopartial

[00:16:36:3F:23:73] ; MAC address of remote machines eth0
model = symmetric
host = ; IP address of remote machine.
inkey = dundi
outkey = dundi
include = priv
permit = priv
qualify = yes
;;;;;;;;;;;;;;;;; end dundi.conf

In /etc/asterisk/extensions_custom.conf on both machines:
[dundi-extens] ; this name comes from the mapping section above.
include => ext-local
include => ext-intercom-users
include => ext-meetme
;;;;;;;;;;;;;;;;;; end extensions_custom.conf

at a command prompt:

cd /var/lib/asterisk/keys

astgenkey –n dundi

See some of the other tutorials about what to do with the .key and .pub files. The name you use needs to match the inkey and outkey in the dundi.conf

Then make a dundi trunk in freepbx. The name of the trunk should match the mappings in dundi.conf. In this case priv. Under outgoing settings dundi mapping you want the same thing priv.

Then make an outbound route that matches your extensions and point it at the IAX trunk.

I had to do a restart on asterisk to get it to work but you may not.

I would link to the docs I got this from but all I have is this from the pdf:

1 Like