Configure TotalPlay Sip Trunk only with IP (provider)


(Jose) #1

Configure TotalPlay Sip Trunk only with IP (provider)

Greetings I have to configure a sip trunk on my freepbx 100, I share the only information that my provider gave me

ipAddress: 10.42.x.x
Gateway: 10.42.x.x
Mask: 255.255.x.x
SBCPROXY: 10.187.x.x
Pilot -> did
722XXXXXXX Extension

what i did was the following
eht4 172.16.1.250/24 GTW172.16… 1.1 Dns 172.16.1.1 local network
eht3 10.42.X.X / 19 GTW 10.42.X.X network provided by totalplay (provider)
to configure the trunk it asks me for the following information

Trunk Name = totalplay
Outboind callerid = 72211XXXXX (my header number)

in sip Settings ”, in“ Outgoing there are two options
Trunk Name = ???
Peer details =? there I suppose I should put the parameters mentioned above ?? or

in sip Settings ”, in“ Outgoing there are two options
usercontext = ???
user details = ??
register string = ??

Now what I have doubt is the following:
1.- It is enough to establish the ip address that gave me total play to the eth3 and connect it to its ont on port lan4
2.-.- it is enough to set the ip address of my lan to eth4 and this is connected by my local network switch
or I have to do more things on the network cards, I am something new in Linux

previously I had this with the axtel provider and without problems but with this provider I only provided the aforementioned information
I’m lost, help, thanks.

sorry for my English


(Dave Burgess) #2

First, switch to PJ-SIP. This should be easier there (since you don’t have to work with two different blocks - one for inbound and one for outbound).

In general, set your Host address to the address that works for you. Your registration string and other registration information in the PJ-SIP setup screen should be set to ‘None’ since you are using IP Authentication. There is no registration information passed when using IP Auth, so you should leave those as ‘None’. Your inbound context (which is the only place that a context makes sense) should probably be “from-trunk” or one of the other variations on that name.

Question 1: Yes, but you are going to have to understand the “route” command settings to get it to work reliably.
Question 2: It should be enough - you will need to make sure that the “default route” for that ethernet port is not set. All “default” traffic (basically anything that isn’t going to a phone or your ITSP) should go through your other ethernet port.