Config not send Config to Sangoma S500 phones from FreePBX GUI buttons

After configuring the extensions and mapping them, FreePBX will not issue the configuration to the phones using the save, rebuild and send option or the button on the right column of endpoint manager

DHCP comes from a CIsco switch and that works (Except option 66 which is on a different thread) the phone all get IPs

I can ping the phones from the FreePBX box on the correct IPs, I can also reach the phones GUI from my workstation… so what can I have wrong where FreePBX wont send the config to the phone?

Has the phone registered with the PBX?

Normally if it is a brand new phone it will show 2 buttons, 1 for internal login and 1 for external button.

Isn’t that for when you use Sangomas servers to auto provision? in any case those buttons are not shown.
A month ago I was only playing with this as a test installation and I didnt have this problem. Had several others but this wasn’t one.
Now that I am trying to make this work for real this has happened.

I can say that this system has no connection to the outside world yet. It’s isolated while I put it together. Could this isolation be related?


Are you using Option 66 on DHCP to send the phones to look at the server?

If you arent are you using the Sangoma Portal for Redirection and is it configured in the portal. If you are using the portal is ports 80-84 forwarded to your PBX through your firewall?


Two issues: 1. I can’t get option 66 to populate on the phone correctly, it gets mangled. I started a separate thread about that.

  1. I know for certain I have configured these phones without using option 66 OR sangoma portal a month ago on a demo machine using ONLY endpoint manager. This machine wont even do that.

Without 66 or Sangoma portal you would have to MANUALLY set the provision address in the phone settings in order to initially point it at your server. Is that what your doing?

I am pretty certain didn’t do that the last time I did this. I had to enter the mac address of the phone into FreePBX and it worked from there.

As I understood it, the provisioning server setting in the phone was optional and just created a way for the phone to auto configure when it gets plugged in. Updating “manually” from FreePBX GUI Endpoint manager would work whether that was configured or not.

But I gotta tell ya, writing that out just now makes me doubt myself. Unless Endpoint manager made a broadcast trying to resolve the mac address to an ip, how would it ever know what IP to use…?

I can say for certain that I have NEVER seen the login buttons. I assumed that was just when you use Sangoma server which I would prefer not to use.

How certain are you that that field is mandatory? Dead sure? Pretty sure?

Like I said, I’m pretty darn sure I didn’t set that field last time. I know for certain I didn’t set option 66 last time. I did have the system manager suite add on installed though. maybe that makes a difference?

If your Sangoma phones are up to date firmware wise you can use the new built in “UPnP Server” that broadcasts to the phones when you boot them. Your “Server Name” will appear on the screen of the phone and you can select OK to program it to that server. This is a newer feature from what I have seen (last 6 months on PBXact).

If you see those login buttons that at LEAST means you should be getting your global provision files but there was no MAC address matched entry in Endpoint Manager.

You can confirm this by just logging into the phone. Click Login - type in the extension and the vmail password then see if it logs in and programs. If so you know communication to the server at least works. I would check your setup in Global Settings for EPM and confirm your internal, external and provision server are all set correctly. :slight_smile:

I do NOT see the login buttons. Never have. No config of any kind has ever been sent to the phones that I can tell.

Okay. i thought that was you earlier that said you saw that. If you are not seeing anything. Then PnP is disabled on your PBX (you need SysAdmin Pro for that i believe. it might be free).

All in all you must either:

  1. Setup PnP
  2. Setup Option 66
  3. Setup Sangoma Redirect portal
  4. Manually enter information into the phone

There is no other way that I know of to provision a phone, especially Sangoma’s. :slight_smile:

“Sangoma Redirect Portal” thats the one hosted by Sangoma?

Yeah its Sangoma’s its more complicated to start with if your not familiar with NATing/firewall’s and what its actually doing. Your best to start off with 1 or 2.

Oh. . . choose ONE of those… Whew. I thought those were 4 steps to a single process !
I will look at them again tonight. I got so burned out failing that I needed to step away and have some success on other things for awhile.

Darn phones started to harsh my mellow :slight_smile:

OK learned something new again today.
The command needed in the Cisco switch issuing DHCP is

option 66 ascii “”

the ASCII option treats the text as well, ascii. Then populates the phone correctly.
Rebooted the phone and all the settings came right in.

Yahoo! moving forward now. Gotta get back with Arielgrin and get my IPTables configured differently to let me activate and get my modules back.

Thanks all, this is a good day.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.