Conference calls muting/dropping on PBXact 25 with Sangoma S505 phones

configuration
freepbx
Tags: #<Tag:0x00007f7027d38148> #<Tag:0x00007f7027e57f88>

(Gabosch) #1

Hello, all. I come to you again with my hat in my hand on an issue that is plaguing a highly irate customer of ours.This issue is happening to all users, and I cannot find the cause.

They are using a PBXact 25 connected directly to the Internet (one port configured for WAN using the Responsive Firewall) and another port for LAN that goes to a PoE switch for their phones. Also, some users are using the Asterisk VPN withtheir Sangoma S505 phones at home.

Whenever they make conference calls from their phones using the conference call button (not the conference bridge), they get about an hour or so into the call and then people stop hearing each other. This happens frequently and I have checked with Flowroute (their SIP provider) to see if this was a limitation on their end and they say it’s not.

Anyway, I do have the log of a call made today to two different cell numbers in a conference call. I have both call item logs. I used Notepad++ to search for the call ID so I could segregate them in separate files without a bunch of other non-call information.

I have tried to figure out the syntax but I’m afraid I am not as well-versed with analysis as I am with writing. If I paste the logs into the pastebin, would someone be able to take a look at the logs (about 238 lines each) and tell me why the RTP is faulting ( I assume it’s RTP; the Flowroute tech also said he thought it was)?

As always, your expert help is appreciated and I try to learn from your advice.

Thanks.

Gary

https://pastebin.freepbx.org/view/0281c974


(Dave Burgess) #2

Check the Forum Search for “30 minutes” and see if any of the NAT transversal problems identified there might solve your issue.

This sounds like what happens when a NAT setting times out. There are a couple of ways to deal with the issue. The first is to set the NAT session expiration on the router to a larger number (not necessarily recommended, but can be effective). There are others as well, including several that involve settings in the extensions. I don’t remember all of the particulars, but the 60-minute thing is the clue that something is expiring after 3600 seconds, and NAT expiry is a safeish bet.


(Gabosch) #3

Thanks for the NAT advice. The system with the issue isn’t going through a router. It’s a PBXact 25 that has two network ports configured, one for the WAN connection straight from the Verizon ONT and the other a LAN connection to the PoE switch powering the phones. I will check the NAT settings in Freepbx. Thanks for the tip.


(Dave Burgess) #4

The gateway router (there is a router there somewhere) could still be timing out the sessions after an hour, even without NAT being an issue. Also, make sure your extensions aren’t timing out after an hour. It might not be NAT, but I’d bet a virtual beer that it will be a session timer somewhere that’s giving up early.


(Gabosch) #5

Unfortunately, I have no access to the gateway router nor does anyone in the company as it’s a .1 FiOS device maintained by Verizon. The PBXact has two NICs configured, one as eth1 with a public static IP and the other as eth0 with a LAN IP that connects to the PoE switch powering their phones. The company is an Ameriprise franchise and their network control is so tight that the VoIP and data networks have to be kept separate. I just opened a ticket with Sangoma but I’m not sure I’m going to get a response in the next few days. The customer is really angry because they rely on conference calls to deal with their customers and brokerages on these calls.

I am not aware of where to check for extensions timing out. Is that in the GUI or do I have to go dabbling in syntax within the system itself?

Thanks much for your assistance.


(Dave Burgess) #6

The discussion in this thread might be illuminating. If you are (and should be) using keep-alives, this will help you understand what needs to be configured.

To be clear - this may not be a setting that has anything to do with the phone. The IT people in your network may have decided that anything that lasts more than an hour needs to be terminated (it’s not uncommon for security engineers to limit connection time to avoid long downloads).


(system) closed #7

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.