Complete Newbie - Phones aren't registering

Just set up freepbx for the first time. Never done anything with voip before. So please bear with me.

So I have set up freepbx and created 2 extensions and then configured 2 phones. No outgoing calls just wanted to test internal calls from one extension to another.

Both phones show offline, but I can turn dnd on and off via feature codes.

When I try calling the other extension I get busy tone.

The calls show up in the Call Even Log

What could be the problem?
Anything else that I can post here that can help anyone to identify what I have done wrong?

Thanks :slight_smile:

Just some starter questions,
-What is the make and model of the phones being tested
-How are they being configured? Manually through their webadmin/config files, or Endpoint Manager?
-Are the phones on the same local subnet as the PBX? If unsure, what is the IP of your PBX and the IP of each test phone?
-For the phone’s registration password, are you using what’s in the Secret field from the FreePBX Extension Settings’ General tab?


  • The 2 phones in question are both Polycom SpectraLink 8440.
  • Both configured via web admin.
  • Phones are on the same subnet as the pbx.
  • yes its is the secret that I am using for the password

Here are a couple of screenshots from the pbx and the phone settings. Maybe I have done something wrong there?

The 2 extensions I have created are 201 and 202

Thanks again for all the help

As I can only upload 1 image per post here is the other one.

depending on what protocol you are using on your phones you may find out that the port is wrong 5061 instead of 5060 as the chansip port is set to 5061 in freePBX and most phones expect it to be 5060.

see this video

Thanks for your suggestion.

I looked through the video before, the only thing that I can see different is that I am using chan_pjsip and not chan_sip.

When I check on the extensions settings, you can see that freepbx shows a notification that it uses port 5060.

Both phones show the green tick at the top right of the screen. If I change port or authentication on the phone that changes to a red cross.

I have set my system up with chan sip can you try that protocol? I am not an expert so cannot offer any more help

I had tested this in the past. still had 2 other extensions on the system. so reconfigured the phones quickly and it worked. lol no idea why it didn’t work in the past but it works now.

Thanks :slight_smile:


thats great

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.