Communication between two PBX-VMs in internal network

Hey!

I set up a VM in the VMWare Player with Debian 8, Asterisk 13.11.2 and FreePBX 13 and cloned it afterwards.
Both VMs are in the same ‘Specific virtual network’ and have Ekiga as a softphone installed.

Now I want to simulate SIP calls between both VMs to see if it works correctly.

Can anyone give me tips on how to realize it? How can one VM reach the other when there’s no outbound CID?

best regards, fabian

Set up local trunks so that each machine can communicate with the other, then set up outbound routes so that the extensions you want to call are routed to the outbound trunk.

In other words, set up PBX-A with extension numbers in the 1000 - 1099 range, and PBX-B in the 1100-1199 range. Set the outbound route to send the calls for the range of the “other” PBX and fire away.

1 Like

Thx for your answer cynjut :slight_smile:

//edit: I deleted most of the post since it was gibberish^^

I used this tutorial for the PBXs https://sysadminman.net/blog/2013/extension-to-extension-calling-between-2-freepbx-systems-5354

  1. Where to set the extension numbers’ range? Has it to be written in the Trunks’ settings under ‘Outbound CallerID’? Just like this: 1000-1999?

  2. What to write in the ‘Route CID’ under ‘Outbound Routes’?

  3. What to fill in under ‘Extensions’?

  • User Extension: Just ‘02’ for the extension itself?
  • Outbound CID: 1000 or 1002 for the extension or can I leave it blank?

thx in advance :slight_smile:

Thanks - we appreciate that.

OK - that’s reasonable. Of course, your questions below are still pretty basic, so it sounds like you need to do some more research.

The “extension range” is largely in your head.

In your outbound route, there’s a place where you match the destination numbers that will be sent to “this route”. In there, you can put something like “10XX” to send all of the calls to 1000 to 1099 down that route.

Nothing - let the extension numbers fly. Also, make this route an “intracompany route”.

You will need an extension number for every phone. This is the number of the phone. The phones won’t ring without extensions. The extension number is how the phone registers.

I wouldn’t use 2-digit extensions, especially ones that start with ‘0’. As a matter of “best practice”, I found that three- or four-digit numbers are good - they’re short enough to be quickly dialed, but long enough to not be mistaken for control codes for the PBX (commands are usually a * followed by one or two digits).

The outbound Caller ID should always be in the form [“Name” <Number>]

When I set up systems, I usually make the extension CID "Employee Handle" <1000> so that the local calls all get plenty of support. When the call goes outside the organization, I set a “trunk” caller ID in the form "Company Name" <8005551212>

1 Like

Great answer, thanks much!!

yep, I’m pretty new to this :stuck_out_tongue:

I think ‘the place’ you’re talking about are the dial patterns, I just put 1xxx into the ‘match pattern’ field, hope that’s right.

It seeeeeems to work now =)

I still have a question left, since I don’t know in how far it depends on maybe wrong settings, I won’t create a new topic for now.
I need a softphone and chose Zoiper, but I can’t register a new account, doesn’t matter what I put in the fields.

for user / [email protected] I tried:

password: the one pbx gives me

Domain:

  • 192.168.80.140
  • 192.168.80.140:4569
  • ‘blank’

I even registered an extension in the /etc/asterisk/iax_custom.conf as shown here http://www.asteriskguru.com/tutorials/zoiper.html, and it’s also shown using ‘iax2 show peers’. Still I can’t register zoiper using this.

If it helps, the VMs are connected via NAT.

//EDIT2: In the asterisk*CLI nothin appears when I try to register a phone

Again, thx in advance!

//EDIT3: I created a new topic regarding softphones/calltoken error