Commercial EPM and Cisco 7941G/7945G not registering

We are trying to set up Commercial EPM for the first time to move from a Ubuntu based FreePBX box to the official Distro. We use Cisco 7941G and Cisco 7945G phones currently and some random Yealink phones. The Yealink phones worked fine in testing and are not an issue. The issue I’m having currently is that when the template goes onto the 7941 or 7945 phones they will not register. I checked the passwords and the template file to be sure as well. The 7941 will register Line1 but Line2 will not register causing the phone to reboot. The 7945 will not register at all. I’ve tried every firmware from 8.4.2 up to the current firmware release. Also even setting the time and other information in the basefile seems to have no affect at all. These phones will work on our old system using OSS EPM and we could continue using that but we’ve purchased the Commercial EPM and want to use it. Any suggestions?

7945 Firmware: 9.4.2.SR1
7941 Firmware: 9.4.2.SR1
EPM version:

Check the length of your passwords. Cisco only supports 31 characters.

Are you setting up line 1 as one extension and line 2 as a different extension?

I know this is an old thread, but did you find a resolution to this, and if so, what was it? Thanks.

BTW, I solved it by using the secret key that FreePBX generated, and took out the last character. Last time I did this, I took out 10 characters. Perhaps the phones are expecting a longer password than that, but when the extension is created, you need to take out ONE of the characters, as it is one too many for a Cisco phone to handle, don’t take out anymore than that. Weird, but I got it working now.