Commercial End Point Manager missing

Hi All,

I have one FreePBX system - FreePBX Distro 5.211.65-19 - where Endpoint Manager has refused to update for several weeks with the following message-

Endpoint Manager cannot be upgraded
Module restart required
Please try again after the dependencies have been installed.

I have restarted Asterisk and the entire server - still unable to upgrade. Hasn’t bothered me enough to really troubleshoot because I haven’t needed it. Today, I need to add a new phone - different make and model than their other phones - and found that Endpoint Manager is not available to choose from the FreePBX interface. Attempted to update again - same result. Found a post where someone had a similar problem and then uninstalled/reinstalled the EPM module and it resolved the issue. I couldn’t uninstall because REST Apps relied on the module. Disabled rest apps to uninstall. that worked. Now I can’t reinstall EPM with out rest apps enabled and rest apps won’t enable without EPM installed! Help!! :smile:


The module named “restart” is required.

The wording of this is fixed in 12.

Thanks for the reply, Andrew! Sorry to be so slow but, where do I find/install the module “restart”. I do not see it in the list on the Module Admin page. I did upgrade to 5.211.65-20 from the CLI - the upgrade reported as working with no issues. But I still am unable to enable REST Phone Applications or re-install the commercial End Point Manager.


From the cli run: amportal a ma install restart

Thanks again for the reply, Andrew, but I must still be missing something

Here’s what I get -

amportal a ma install restart

Fetching FreePBX settings with gen_amp_conf.php…

The following error(s) occured:

  • Cannot find module


amportal a ma download restart
amportal a ma install restart

Thank you again, Andrew!

In all of this, the config files generated by EPM are still in /tftproot. But, the templates I’d built are no longer available in the Commercial EPM module. I do have a full FreePBX backup of the server. Are there specific files I can restore from the backup, or import from another location on the server, or, do I need to re-create the templates from scratch again?

Learning a lot - thanks again!