Comcast business class modem - ugh - stopping voip traffic?

I know this is not a freepbx issue but I figure someone on here has had to have this issue.

Business has 10 phones at their location. They move to another location just down the road. At the new location they have a Comcast Business Class Gigabit router. They plug in all their phones to a beautifully done Category 6 only network with POE to the 10 locations. The phones fire up, turn green and calls begin to flow . . . .for a few minutes that is

They all go orange - the dreaded color of voip. After extensive research it was found that Comcast Business Class modems (which you are required to use for this type of service) typically have this issue. Sip ALG or ports being blocked trying to force you to use their voip service.

I can reboot the phones, reboot the cloud freepbx, but within minutes, all goes south.

At one point the phones were successfully registered but could not dial ext to ext, although they could dial outbound with no problem. When you tried to dial ext to ext it said , 403 service unavailable.

If anyone has any work arounds, advice, tips or tricks to get around this I would be most appreciative.

Ideally you would have the ISP disable the ALG in the router. I have heard of people successfully using TLS for SIP signalling to avoid the problem.

Unfortunately I have to deal with Comcast on a daily basis with my freePBX clients.

We had one client that did upgrade to the Comcast gigabit offering and I had it pulled out within 48 hours after it was installed. Nothing but problems Comcast is flying by the seat of their pants and has no idea what was going on.

I would highly recommend the following

100 meg down 20 meg up service seems to work great

Get a static IP address from Comcast

Have Comcast provision the modem in “virtual bridge mode”. All you want this modem to do is to simply pass you all packets of information. Not to block anything not to filter anything not to change those packets in anyway.

Get yourself a nice router that plays well with VoIP. I can highly recommend the ubiquity edge router lite just make sure the sip ALG is turned off in the router. Program your routers IP information with the Comcast static IP information.

As long as the modem has been provisioned in what Comcast calls “virtual IP mode”, and you’re communicating via the static IP address” and you have turned off the sip ALG in your router, you should be good to go. I have a large number of clients set up exactly like this without issue.

Once you have established that good connection be aware that, at least in our area, we are constantly having to monitor the quality of the Comcast connection.

I am not necessarily referring to only speed but more packet loss and latency. You need to constantly monitor the Comcast connection so that when a customer calls and complains about their phones you have something to refer to so that you know exactly how that Internet connection has been acting over the last 72 hours at a minimum. Just one man’s opinion.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.