Cisco SPA303 Registration Help


#1

I’m setting up a very tiny FreePBX instance for the kids to be able to call each other from their rooms. I have a VM built from the latest official iso and all I’m trying to do is create 4 extensions and register a few Cisco SPA303 phones and a few iOS SIP softphones. I created 4 extensions using the quick extension option and selected a pjsip extension. The extension is a single digit and the username was created automatically. I went into the user id and changed the password. When I go into the SPA303 I factory reset the phone, went into Line 1 and entered the private IP of the FreePBX server into the Proxy field with port number following e.g. 192.168.1.2:5060 and then entered the user id (3) and password I set in the user manager. The phone only displays an authentication failure and the /var/log/asterisk/full log shows the same authentication error without any additional detail.

I’ve tried numerous short passwords with no change. This is my first time using FreePBX so I know it must be something stupid, but I can’t seem to figure out what I’m doing wrong. If anyone can point me in the right direction, I would really appreciate it.

Thanks!


#2

The user manager info is not the data you use to register a phone. You use the data from the pjsip extension, the extension number is the username and the password is the one defined in the extension, not the one defined in user manager.


#3

Cool, I just found someone else reference the secret and not password, that was my confusion. As soon as I updated the SIP info to use the secret on phone (and removed the ban from fail2ban) it worked!


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.