Cisco SPA303 lines keep switching between green and amber


I know similar issue has been reported many times over the years but I don’t seem to be able to figure this out. All of a sudden, Cisco phones at a particular remote office would keep switching back and forth between green and amber.
I understand this means they’re losing their registration but then they recover on the their own a little while later. They keep doing that all day long and they would have different state at different times: some would be ok and others would be amber at any given time!

Backend is FreePBX server 15.0.37 and we’re using PJSIP
Current Asterisk Version: 18.16.0
Phones firmware is: 7.6.1

The weird thing is that there are multiple remote locations being supported on this server. None of the other locations are having this issue and all use the same Cisco phone model.

FreePBX server is configured with a public static IP. I am inclined to think that the router at that location is not doing NAT translation correctly! They use a Netgear Nighthawk MR60 at that office.

What can I look at in the logs or anywhere else to troubleshoot this issue?

Thanks in advance for any help!

Adding more details, on the “Asterisk Info” page (Peers tab), it always show that the endpoints are registered and available (never shows them as offline) even when on the phone side it thinks otherwise.

As a matter of fact, right now it shows this on the server side (for security replacing ext nb with XXX and IP address YYY.YYY.YYY.YYY):

Endpoint: XXX/XXX Not in use 0 of inf
OutAuth: XXX-auth/XXX
InAuth: XXX-auth/XXX
Aor: XXX 1
Contact: XXX/sip:[email protected]:5068;x-ast-orig- 2af8bd3210 Avail 92.978

While on the phone web interface Info page, it says (thinks it’s offline):
Registration State: Failed - No Response

By the time I was about to send this, it changed to (on the phone):
Registration State: Registered
Next Registration In: 16 s

So it seems to me that FreePBX server is sending back replies but sometimes the phone is not getting them!

Thanks again for any pointers to where to look

Do you have a ‘SIP helper’ (ALG) enabled on the problematic router, if you do then likely all registrations/invites will seem to be accepted but replies from the server will only be forwarded by that router to the ‘most recent extension registering’ at that instant

In addition to confirming any ALG turned off as @dicko said, I assume that you tried rebooting router and modem.

What, if anything, appears in the Asterisk log for failed registration attempts?

Does the MR60 have a public IP address on its WAN interface? If not, please explain (ISP modem configured as gateway, ISP does CGNAT, etc.)

At the Asterisk command prompt, type
pjsip show aor XXX
(replace XXX with an affected extension number)
and report the port number shown in ‘contact’ and the value of remove_existing.

(You can alternatively select separate ports for each ‘line’ on such venerable Sipura’s with funky routers)

Yes there is such an option and I made sure to look for it and disable it (it was enabled). Unfortunately with ALG disabled, the problem persists

That’s correct. Both were rebooted.
Charter Communications provides the internet at the site and they provided the modem which I assume is in bridge mode because the router WAN port gets DHCP public IP from them.

I’m not seeing failed registration attempts in the log file!

from the output of: pjsip show aor XXX
contact : sip:[email protected]:5060;x-ast-orig-host=192.168.ZZZ.ZZZ:5060
remove_existing : true

(YYY.YYY.YYY.YYY is the public IP address of the router)

I hope that only one extension looks like that; the router must rewrite the source port number to unique values for the others. Possibly, even with ALG off, it’s not doing that correctly.

Try setting SIP Port in each phone to a unique value, not using 5060. For example, set 6500, 6501, 6502, …

If no luck, we can capture traffic at both ends to see whether the router is messing things up.

We’ve actually always used different SIP port numbers for the different phones at any one particular site (just to be on the safe side knowing some router implementations may not be as good).

In this case, you’ll see that the next phone uses 5061 as SIP port (and it shows as such in both places in ‘contact’ when you run the command "pjsip show aor " you mentioned before)
And then 5062 for the next phone and so on and so forth.

But we will test shortly with ports other than 5060 as you recommended.

I am also now thinking: could the cable internet provider have made changes on the modem that somehow enabled some type of filtering (even though in bridge mode) that interfere with SIP messaging? It may be worth calling their tech support to make sure.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.