Cisco PAP2 with EndPoint Manager


(A Crawford) #1

So I have done my extensive research on trying to make the Cisco devices work with EndPoint manager, and it appears to be a big headache. As much of a problem it is, I have not found any solid answer to my problem.

I have the Linksys (Cisco) SPA1001 which I am trying to setup for auto provision on my PBX server. I know the auto provision works as I used it on one of my Grandstream office phones and it worked like a charm. It appears that the PAP2 devices are not so simple to setup. I am pretty sure that it is the profile rule I need to change, but cannot find a clear answer on the forum what to set it to. Keep in mind, I am not using a TFTP server. I am attempting to do this all over HTTP.

I have tried profiles such as;
http://serverip:83
http://serverip:83/spa$MA
http://serverip/spa$MA
http://serverip/$MA

etc etc etc. and multiple variations of such. Any help on this would be great, so that I can have others program these things simply, and do remote configs on them as well.


(Chris Dolese) #2

Biggest pita I recall was they shipped in route mode and lan side did not have dhcp enabled or something like that

There there are dtmf sequences that can take it out of route mode as well and to enable dhcp - otherwise you have to go through a few gyrations to admin via browser

Once out of route mode? they behaved well with option 66 and picked up epm configs

If you want to use a profile rule manually the format I have noted is:

http://my.pbx.iporhost:84/spa$MA.xml
(Assuming http prov is set up on 84)

Admin guide for internal IVR config …


(Options 201 and 101 are the items I recall)


(A Crawford) #3

Thankfully mine all ship in DHCP. Its a pretty basic, and easy config for myself. After 3 years for doing these it takes 30 seconds to do one, but unfortunately its time to move on from just me and have more functionality.

As for manually setting the rule, I have done that, except on port 83 as PBX default set it to that and I can’t change it. I have also attached a picture of the provisioning screen. Maybe I’m missing more, or maybe it’s just a cisco thing. I have never played with auto provision before.


(A Crawford) #4

Update: After 20 minutes idle, it did auto provision itself.

My next question, through basefile edit, am I able to tell it to turn on NAT Mapping, as well as change the ring waveform?


(A Crawford) #5

I have answered my own question. Basefile edit is actually very easy to figure out. Just select your device that you will be doing, and the parameter will be exactly how it is shown in your device. ie. Ring Waveform is inputted into parameters as Ring_Waveform then set your value to whatever is available as an option, ie. Sinusoid

It was able to recognize the parameter and change it to my preferred setup. Next step is to see if I can have the server force the profile rule on to the ATA so that they don’t even need logged in to, but I feel that might not be possible as the ATA needs to be able to talk back to the server. More updates to follow as I progress along.


(A Crawford) #6

So the server cant force provision the rule, which I was pretty much expecting. The profile rule needs to be set so that it can talk back to the server. But other than that, with editing the basefiles, I am able to fully provision the ATA to my standard, with the only change being to the profile rule.

Thank you for the help @dolesec very much appreciated!