Cisco DX-80 and SIP URI Dialing issue


(Dave Burgess) #21

I know nothing about the DX-80, but if it will work with SCCP, you might want to get into the Discussion forums on the GitHub repo for Chan-SCCP-B and ask Dietrich if this is supported there.

If the phone doesn’t support Skinny, then never mind obviously, but this sounds like something right up their alley.


#22

Here is the data sheet I posted earlier. It’s a newer device and does not implement SCCP.


(Glen) #23

Well…here is the news!

I was suspicious of Zoiper and a codec issue. Zoiper wants you to pay for H.264 otherwise it will only use VP8. FreePBX/Asterisk does support VP8, I made sure it was enabled and at the top of the codec list. Still nothing worked. I put down the iPhone and installed Linphone on my PC with the H.264 codec.

Two things happened:

  1. A call from the DX-80 to the PC resulted in two way audio/video(BOOM!)
  2. A call from Linphone resulted in the PC receiving video from the DX-80 but the DX-80 displayed no video from the PC. Place the call on hold on the DX-80, pick it back up and poof. Bidirectional audio and video. Every time. That’s a problem I will chase down later. At least it works!

Thank you everyone for trying to help me figure this out.

Now back to the original question that got us here. If you saw my original post, how can I add URI dialing to my dial?

When I try to dial "wbdemo@conf.zipdx.com" or "user@company.webex.com" etc. it fails. I could paste the whole log here but I think this is a problem someone knows the answer to…ultimately the ending errors are:
[2021-01-07 18:33:37] NOTICE [9956]: res_pjsip_session.c : 4007 new_invite : 2100: Call (TCP:192.168.1.12:42659) to extension ‘wbdemo’ rejected because extension not found in context ‘from-internal’.

[2021-01-07 18:33:37] DEBUG [9956]: res_pjsip_session.c : 4007 new_invite : 2100: Call (TCP:192.168.1.12:42659) to extension ‘wbdemo’ rejected because extension not found in context ‘from-internal’.

[2021-01-07 18:33:37] DEBUG [9956]: res_pjsip_session.c : 4479 handle_outgoing_response : 2100: Method is INVITE, Response is 404 Not Found

So the INVITE fails with the 404 Not Found error.

@Stewart1 - I could live with the dedicated extension as previously suggested If I had to. When setting the extension to “SIP/wbdemo@conf.zipdx.com” I get audio only. I don’t know if there is supposed to be video.

@billsimon If I paste “SIP/8008675309@zoomcrc.com” into the dial field, I get the screen and audio that you showed above. If I try to use “PJSIP/anonymous/sip:8008675309@zoomcrc.com” as you have it typed, it fails and doesn’t even show up in my sngrep list.

There is a fairly old article on how to accomplish this task and it is for a much earlier version of Asterisk. Here is the article https://www.voip-info.org/asterisk-tips-sip-uri-dial so i would think there still has to be a way to make it work.

I am using FreePBX so you’ll have to scroll half way through the article where the author says what to do if you’re using FreePBX. I tried it(i think correctly) but it’s beyond my understanding of asterisk.

Thank you again to everyone who is chiming in to help!
Glen


#24

SIP/ tells asterisk to use the chan_sip driver; PJSIP/ tells it to use PJSIP. I standardized on PJSIP and disabled chan_sip altogether, though there’s nothing wrong with using both except that it makes your configuration more complicated.

To be able to call out to a URI using the “PJSIP/anonymous” endpoint you have to have the endpoint enabled by going to Asterisk SIP Settings and turning on Allow SIP Guest.

What does the asterisk full log show when you do this?

BTW all the articles on voip-info.org are outdated and probably shouldn’t be used. The forum is current and active though.


(Glen) #25

@billsimon - me too. My entire setup(extensions/trunks) are PJSIP. Chan_sip is installed but just not disabled. That’s where my confusion comes in. Why wouldn’t PJSIP sucessfully dial but chan_sip did?
pcaps.tgz (5.6 KB)

I could definitely tell the information on voip-info.org was old - my hope that was since there was a way to do it in an old version, something similar existed in this one.

Like I said, I can live with the dedicated extension, but would love the flexibility of jus typing in the address instead of having to edit the extension every time. Plus it’s an interesting exercise and I’m learning a ton as I go!
Glen


#26

Please confirm / post asterisk logs.


(Glen) #27

I have no idea if this is helpful to you. The SIP logs are in the previous message under pcaps.tgz. This is the asterisk log with the debug level at 2 so you didn’t get those ridiculously large logs as before. I hope it’s enough!

SIP/xxxxx continues to work fine.
PJSIP/xxxxx continues to fail.

This is a log of extension 2100 call 2200. Extension 2200 has PJSIP/anonymous/sip:94598894228@zoomcrc.com in the dial field.

Glen


(Glen) #28

I’m sorry - forget to include that I do already have Allow SIP Guest turned on.


#29

Lines 1225/1226 of your Asterisk log show that the call is sent to Zoom and responded to. We can also see why it does not appear in sngrep: it’s using TLS to call out.

Try adding \;transport=TCP to the end of your dial string to force it to use TCP instead of TLS. Then you should be able to see the signaling in sngrep.

I suspect Zoom is rejecting the call because video is not offered through the anonymous endpoint. I added the following to my /etc/asterisk/pjsip.endpoint_custom_post.conf file to have it handle NAT situations and video on SIP URI calls:

[anonymous](+)
rtp_symmetric=yes
force_rport=yes
rewrite_contact=yes
direct_media=no
disallow=all
allow=ulaw,h264

after you add that block, do a fwconsole reload from ssh to ingest the new settings.


(Glen) #30

Thank you Bill. I will have to try that and I’ll report back.