Cisco & Aastra Phones not registering

I installed the FreePBS Distro a couple of weeks ago on a server. I tried many hours to get several phones to register without success. I was using OSS EPM. A couple of days ago I purchased the Commerical EPM thinking my issues were related to the configurations of the phones and they probably are but I am still unable to get any phones to register.

I have 2 Cisco 7941G, 1 Cisco 7965G, 1 Cisco 1 Aastra 6753i plugged into my switch with the Asterisk Server. The DHCP and options are configured correctly as the files are being downloaded by each phone. The 7941s go into a constant reboot cycle trying to register. The Aastra seems to be up but it is not showing up as registered. The 7960 shows a x by the telephone icon by line 1. It does have a dialtone on line 1 which is the only line I have configured. The 7965 constantly says registering, has an x by the telephone icon.

The message in the full log is “[2014-03-21 00:56:00] NOTICE[1870] chan_sip.c: Registration from ‘sip:[email protected]’ failed for ‘’ - Wrong password”

This is the same message I got when I was using OSS EPM and it is the same for all attached phones.

sip show peers shows the list of 5 phones but all 5 show offline.

Anyone? Bump!

If the phones are providing wrong password, or did at one point it is likely that they are “fail2banned” you can first confirm they have the correct SIP password loaded, then either stop or reload fail to ban or turn off iptables for a minute to see if that is the issue.

I finally got the 7941G phones to register. FreePBX Extensions was creating a 16 octet hexdecimal password, which was not being accepted. I manually input in a password, currently 9 digits, and all the 7941g phones booted up and are not registered. Still have not got the 7965g phones running yet.

I tried configuriong the phones with OSS Endpoint and that didn’t work so I purchased the Commercial EPM and that did’t work either. I am back at the OSS EPM and working fine once I input my own passwords. Later I am going to do some more playing with the length of the passwords to see what the max length is but for now, I am fine with a 9 digit password!