FreePBX | Register | Issues | Wiki | Portal | Support

Cisco 8945 can not download config files from freepbx tftpboot


(Roney) #1

hello there can anyone help me what to do boot from freepbx tftp server for cisco 8945 phones.I want to use cisco phone with freepbx.i tried everything as tftp is running i can download the files using tftp client from windows and also i can see the cisco phone hits on freepbx at 69 port using tcpdump command but in phone its showing can not download the files.


#2

If the phones and PBX are not on the same LAN, please describe your network config.

Try briefly disabling any firewall in the path.

Use tcpdump to capture an attempted boot, move the capture file (e.g. with psftp) to your PC, open it in Wireshark and see what filename it’s trying to read, what error response is being given, etc.


(Roney) #3

both are same lan.i have already checked the tcpdump in that i see that phone ip is requesting the files but in phone it shows cant download file and update failed.no firewall there.interesting thing is i dont see any packet in wireshark if i filter it with my phone ip.
i have confusion that does my SEPMAC.cnf.xml file is ok or not?

<?xml version="1.0" encoding="UTF-8"?> 1 SIP admin password D/M/YA GMT Standard/Daylight Time 172.26.7.200 Unicast 2000 5160 5061 172.26.7.200 5160 true true x-serviceuri-cfwdall x-cisco-serviceuri-pickup x-cisco-serviceuri-opickup x-cisco-serviceuri-gpickup x-cisco-serviceuri-meetme x-cisco-serviceuri-abbrdial false 2 1 true true 0 2 0 true false 6 10 180 3600 5 120 120 5 500 4000 70 false None 1 false true false false 101 3 avt false false 3 Front Desk 2 false 10 false 9 Front Desk - 100 USECALLMANAGER 5160 100 100 0 3 100 Cisco@123 false 1 *97 4 5 1001 2 true false false true 21 Voicemail *97 21 Toggle Busy *76 21 Kicthen 200 5160 16348 20134 184 0 dialplan.xml true 2 SIP894x.9-2-1-00 SIP894x.9-2-1-00 1 1 1 false false 0 1 1 1 1 0 0 08:00 16:00 00:10 1 1 1 English_United_States en 1.0.0.0-1 iso-8859-1 United_States 1.0.0.0-1 1 96 0 96 2 0 3804 false

#4

Something is very wrong. Start the capture with a command like:
tcpdump -s 0 -w foo.pcap
Reboot phone and wait for download to fail.
Type ctrl-C to stop capture
Move foo.pcap to your PC and open it in Wireshark.
Set display filter to “tftp” (without the quotes).
Report what you see.

Your config file was garbled by the forum. Paste it at http://pastebin.freepbx.org/ and post a link.


(Roney) #5

problem solved by tftpd option
disable=false